Can't Get Ardour Inputs to Hear S/PDIF or Scarlett 2i2

I just created a DAW station on on new hardware with Ubuntu Studio 14.04. I’m using Ardour and Jack. For audio devices I have an M-Audio Audiophile 2496 and a Scarlett 2i2.

I can record fine from the M-Audio 2496 two analog audio inputs. However, I can’t get a peep out of either the Scarlett 2i2 or the M-Audio S/PDIF input. I played with Jack quite a bit, using the Setup dialog to specifically select the hardware input and nothing changes the results. I’ve connected ALL 12 of the system capture devices to my record track in Ardour and still nothing from S/PDIF or 2i2. I know the devices work because I tested them in a Windows machine I have.

I’m sure I must be not setting something up right, but I have no idea what. Any help appreciated.

My first thought, do you have the clock settings correct? Meaning is the M-Audio or the Scarlett device set to the same sample rate via Jack as whatever signal is coming in through the S/PDIF port?

Second thought, have you checked in alsamixer (Or the equivalent Scarlett mixer I can’t remember the name of) to make sure there is nothing odd in those settings?


Thanks for the reply! I can check the clock settings. They’re all at the default. The Scarlett 2i2, though, doesn’t use S/PDIF. It comes in through USB. I don’t know of an alsamixer like app for it. At least in all my Google searching I haven’t encountered one. I did run the Envy24 mixer (a GUI equivalent of the alsamixer) and made sure the S/PDIF inputs on the M-Audio were not muted. I’ll keep looking around at settings. I’m thinking this is more of an Ubuntu issue, not an Ardour issue, trying to connect via these inputs.

Ahh my fault I misunderstood.

In as far as an alsamixer like app for the scarlett, try reading through this…


By the way, it may be the 2i2 doesn’t need it as there isn’t a lot to mix in it, but that would be where I might start.


Thanks seablade. I’ll have a look at that. What’s frustrating is all the Google searching I’ve done shows that the 2i2 “just works” for others. No problems reported. So I don’t know why mine’s not working. The Ubuntu sound settings shows the device, so it’s recognized by the system. From the Jack perspective, all I ever see is the same 12 inputs (capture_1 through capture_12) available from “system” regardless of what I force the input hardware setting to be in “Setup…”. From what I’ve read, these 12 inputs represent inputs from the M-Audio card, but I’m not totally sure on that.

@mbratch open qjackctl --> Setup button --> “interface” comboBox. In this comboBox select your device (scarlett). be aware that in qjackctl you can setup one card as input and another as output but no two as input and/or two as output. (Correct me if im wrong @seablade)

@davidpucheta I had already done that. I opened the setup combo box and have individually tried every one of the different hardware options available for the input selection. No change in symptoms.

@mbratch: Silly question, but do you stop jack and restart it after changing devices in qjackctl?

@mbratch And to extend the silliness a bit farther, you might want to verify that there are no other JACK processes running, even if you think you’ve stopped it with qjackctl. I’ve been bitten by processes previously started by Ardour(4.0), for example, which qjackctl didn’t see.

OK I made a little progress… I think. Sometimes when I start Ardour it asks me what audio mechanism I want to use, but sometimes it doesn’t (I haven’t quite figured out when it chooses to do this). I just donated and installed Ardour 4, and it asked me. I chose ALSA this time, and it let me choose between the Audiophile 2496 and the Scarlett 2i2, so I chose the 2i2. Now I can record from the 2i2, but I can’t get any output on the Audiophile. I did read that the software can only handle one device at a time, but I didn’t realize I can’t monitor on one whilst recording on another. That seems severely limiting and contrary to simpler programs I’ve used on Windows. Is this really the way it works? And when I have the 2496 selected, I can’t seem to get to the SPDIF (I tried all 12 capture inputs under system). And finally, once selected, I can’t figure out how to get Ardour to choose a different device. So right now both my Ardour 3 and 4 are fixed on 2i2 as an audio device and I can’t choose the 2496.

I did read the manual but either it doesn’t discuss this, or I missed it.

By the way, im pretty sure that inputs 9 and 10 are your 2496 S/PDIF inputs. Try to rec enable these inputs from also mixer and then try to record something from those inputs to troubleshoot your M Audio card. On the other question the ALSA engine won’t let you use more than one interface. You can do this with Jack only. Read this:

as to the 2496
analog ports are 1 and 2, digital ports are 9 and 10
(applies both to input and output)

in order to use digital in: run program “envy24 control” (or mudita) -> hardware settings - Master clock must be set to spdif in

I would try running Ardour with Jack instead of alsa and choosing the device. It is a little confusing at startup with Ardour 4 now.
When I first used it I already had Jack running and it asked me what settings I wanted to use. I started it by choosing Jack but it seemed to not use the same settings of the running jack process. I shut Ardour down and restarted it and it never asked again and used the running process of jack.
Another note about the 2496. On the Patchbay/Router page of Envy24Control, if you activate “Digital Mix L/R”, then on the Monitor Inputs page you can unmute the inputs 1 & 2 and monitor those inputs with “zero” latency. Or anyway bypassing jack or any other software and going from in to out directly through the card.

OK, thanks for all the great tips! So setting the master clock to “SPDIF in” in mudita did the trick on SPDIF.

I did read that manual page before on multiple sound devices, but I was reading so much of the manual at the time, I had forgotten about it. It appears that, if I want to use both my 2496 and 2i2 in the same session, it looks like the most recommended approach is to install a couple of programs called “alsa_in” and “alsa_out”, and then I can use Jack to logically have both connected in. So I’ll be off to try that out…

But I feel like I’ve made progress in getting things working and understanding it better. So, again. thanks everyone for your courteous and informative answers.

So I figured out using “alsa_in” how to get the 2i2 working as well. That’s all good. But now all my output sound stopped working and everything looks normal in Jack. Oy, it never ends…

you should use zita_a2j (part of a package that is likely called zita-ajbridge) rather than alsa_in/out. It has better quality resampling and less CPU. It is also built-in to current versions of JACK1, but you are likely using JACK2.

OK, I see those. Thanks. For some reason JACK2 is now choosing something different for default sound I/O (the motherboard sound hardware I think). It just shows 2 available inputs and outputs. All no matter what I choose in the Setup dialog. This JACK2 program is a mystery to me how it decides to choose hardware. I can’t seem to control it at all.

JACK (1 or 2) defaults to the first sound device recognised by the system unless told otherwise. Look in /proc/asound to see in which order the system sees your sound devices. You may need to disable the motherboard sound device in the BIOS settings if you don’t want it getting in the way.

Also check you don’t have pulseaudio running.

And see the JACK FAQ at for information on how to refer to specific devices with persistent names no matter what order they are discovered in during boot up. The JACK FAQ also has lots more information as well.