Can't get any sound under Ubuntu 6.10

I’m trying Ardour2 under Ubuntu Linux 6.10. I’ve created an audio track and inserted a wav audio file, and when playing I can’t get any sound.
I edit the output in the mixer for the master channel and this is what I have:



I’ve tried with other configurations without luck.

I hope you could help me.

Thanks in advance.

I, too, have this problem (my latest :P). My scenario and settings are almost exactly the same.

Do you get sound with the normal musicplayer?

If yes, how did you start jackd?

Normally the soundcard is blocked for jackd if the normal sound daemon runs. Jackd uses the next card or a dummy. Try to killall -9 “esd”, “artsd” and then start a new jackd that uses your soundcard. Then you can start ardour after that. It will use the jackd you started. If you still hear no sound, make sure that you didn’t accidentally start esd or artsd again.

Ok, I killed esd and now it works. I suppose it is because I have installed Enlightment packages because esd seems to be Enlightment sound daemon.

Okay where do I put that command line? I use qjackctl to start it up. I see command lines in the “Setup” button under the Options tag. Where and how would I set up to kill esd?

You have to open a terminal window and enter the command to kill esd. Then start Ardour and it should work.
By the way, I don’t start jack manually because ardour does it whenever it’s started.

…other ways, if you start jackd vie qjackctl, you have much better control about performance, connections etc.

if you open the settings dialog in qjackctl, choose ‘options’ and activate the first line in it ‘execute script on startup’ and add:

‘artsshell -q terminate’

into it.
so it is working here.


EDIT: Okay I solved everything, got sound and everything.

Next question (as opposed to making a whole new thread). So I try and import audio ripped straight off a CD. Jack is set to 44.1 khz, the wave is a 44.1 khz stereo .wav file. It plays just fine in a music player. When I pull up the import screen and play it in there (before importing) there’s a lot of cracking and buzzing, almost as if it was clipping. This is the same when I actually import this.

That may be just due to latency problems. If you’re using Ubuntu I suggest you look at this documentation to help tweak Jack for good latency on your system:

The StudioPreparation page is key if you haven’t read that yet, it will walk you through setting up the right permissions for realtime audio.

Hope that helps

Hmmm, I get an interesting effect. I had a fairly high latency (50 ms or so) but after fiddling with what the first link said, I dropped it down to less than 5 but then it sounded much worse!

Oh well that’s an onboard soundcard for you. Well, not only do I have to wait for a Firestudio, I have to wait for the drivers to come out for it :frowning: