Can't get a perfect loop in Ardour 4 and 5

Hi,

First of all, I’d like to say thank you all for such a great app,

But recently I got struggle in a serious problem, I can’t get a perfect loop in Ardour 4* and 5*, even with a simple and continuous sine wave,
The thing is that when I place two regions next each other, it just can’t play them smoothly without that annoying CLICK in the middle. If I add a lot of crossfades, the click is gone of course but I can’t place such crossfades at the end of loop or at beginning. Also, crossfades destroying the wave and I need to get the perfect continuous loop without crossfades.

Honestly, I’ve been researching this for many days and tried everything I can think of, but still can’t get the perfect loop. I got this problem with the Ardour 5.2 (debian10), and then I tried to reinstall my Linux to get an older one (Ardour4, ubuntu16), but the program still can’t make the perfect loop without that pop-click.

I prepared a special ardour file to save your time from trying to understand about what I’m talking about, here is is, for the latest Ardour 5.12. (I have pretty similar problem with Ardour 4.)

.zip archive with it to see the problem, 5mb: https://yadi.sk/d/jVzeEZOx7V1ySQ

Also, could you please advice, where can I get the classic old 2.8 version of Ardour? I need a compiled package that I can easily run on any modern linux, I’m ready to pay for it or something. As far as I remember, Ardour 2.8 had no such problems with looping — regards, z.

There are three issues here.

First of all, the loop-length needs to be an example multiple of the sine-wave period, otherwise there is a discontinuity which will result in an audible artifact (usually a loud high-frequency click).

To avoid this issue in Ardour, region-fades are automatically added at region-boundaries. This mitigates the effect of slicing off the signal in the middle of nonzero energy.

You can avoid that fade by looping the middle of a region (without region-boundary fades), or by disabling Session > Properties > Fades > Region fades active in Ardour.

Last, in Ardour 5, you need to enable Preferences > Transport > Do seamless looping (otherwise Ardour’s transport is stopped, located, and playback is resumed).

(Ardour6 only does seamless looping, and has a “Loop Fades” preference, set it to “No fades at loop boundaries”)

1 Like