Can't add most plugins to tracks (V6.9) Windows

Before I was able to add plugins like the EQ and Delay and such, but now when I try to add them it crashes ardour entirely with no prompts or error messages. It works fine when I add Reverb, but most others cause this issue. I have tried re-installing multiple times and have tried different versions, but no luck.

Anyone else having this issue or know what may be causing it?

(also if this is just caused by the standard plugins, does anyone know where I can get some others that may function better?)

Thanks in advance

To be clear, these are the ACE plugins causing this?

   Seablade

Yes, strictly using the ACE ones

I cannot recreate what you describe using Ardour 6.9 on Windows 10 Pro. All ACE plugins load fine for me. There can be a lot of variables to control, and information needed, to get to the bottom of your issue. This may not get solved on the forum. My recommendation would be to file a report on the tracker by following the instructions here:

See here:

Try updating your graphics card driver, it seems to likely be caused by an issue with OpenGL.

In as far as other plugins, there are lots of options. A quick search on KVR will reveal many, and of course there are more than a few suites mentioned on these forums as well (Open Source and Commercial).

    Seablade

Thanks, I’ll give this a go