Cannot uninstall Ardour (Solved)

I have Ubuntu 21.10. My PC was crashing and turning off suddenly a lot when using Ardour with JACK and yoshimi, so I assumed it had to do with the real time priority of jack. I changed its values with renice, but nothing changed and I didn’t found anything more that I could do (I’m very much a beginner in this) and decided to uninstall all of the programs to not concede real time priority for jack in the installation this time. I removed jackd first and, when I tried to remove ardour with Ubuntu Software, it showed up like this.

Then I tried to do it with sudo apt-get remove, purge etc, and it always results in

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'ardour' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.

Trying the cd /opt described in the “before you start” page of the site gives me this:

sh ./Ardour_6.9.0.uninstall.sh
sh: 0: cannot open ./Ardour_6.9.0.uninstall.sh: No such file

But the program still shows up when I search for it and still opens! It opens as the first time running it, with the configuration and welcome sessions, but it opens normally. I’m very lost. Trying to remove it with app finder just opens the Ubuntu Software again, with that same error page. I removed all folders and files that I could find searching for ardour in the archives explorer, but nothing changed.

Don’t know if it is related, but I also had this warning during the installation: "!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency.
For best results turn it off, e.g. by chosing the ‘performance’ governor.” But, after a lot of searching, I discovered my system apparently cannot run performance mode.

I assume I made a mistake removing JACK first or maybe I’m just doing a lot of dumb things.

How have you installed Ardour?

Did you get it from http://ardour.org/download.html ?
If so

/opt/Ardour-6.9.0.uninstall.sh

should work.

It gave me this

Removing existing Ardour installation at /opt/Ardour-6.9.0

/opt/Ardour-6.9.0.uninstall.sh: 159: [: /home/owas/Area: unexpected operator

oh yes it worked! thank you

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.