Cannot start JACK/permissions issue

So, while wrestling with a security issue, I haphazardly changed the permissions of my /home file structures, and have been plagued with the following:

server default' registered cannot create /dev/shm/jack-1000 directory (Read-only file system) cannot create server sockets cannot create engine cleaning up shared memory cleaning up files unregistering serverdefault’
18:06:52.541 JACK was stopped successfully.
18:06:52.541 Post-shutdown script…
18:06:52.541 killall jackd
jackd: no process killed
18:06:52.728 MIDI connection change.
18:06:52.750 Post-shutdown script terminated with exit status=256.
18:06:56.753 Could not connect to JACK server as client. Please check the messages window for more info.
JACK tmpdir identified as [/dev/shm]

I’ve tried to chmod /dev/shm, but it still will not create the temporary directory needed. What should I do? How are these things typically troubleshot?

And…are there any more issues I can expect from my mistake? What permissions does JACK require to run?

Thanks in advance…

please paste the contents of /etc/fstab

Since there’s the error message stating a read-only-fs, also the output of ‘mount’ would be helpful.

Thanks, guys. Here’s fstab:

/etc/fstab: static file system information.

proc /proc proc defaults 0 0


UUID=bdeba473-e725-4efe-8b01-fa53de797837 / ext3 defaults,errors=remount-ro 0 1


UUID=61eb9cdf-9f70-4cfb-a2a4-647feddc21eb none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/hdb /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
/dev/sdb5 /media/mountpoint ext3 rw,auto,user,exec 0 0
tmpfs /dev/shm tmpfs defaults,ro 0 0

…and here’s mount:

/dev/sda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.22-15-rt/volatile type tmpfs (rw)
/dev/sdb5 on /media/mountpoint type ext3 (rw,nosuid,nodev)
tmpfs on /dev/shm type tmpfs (ro)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

Thanks for your time. If there is a good recommendation for a ‘newbie-friendly’ source of security issues with linux OS, I’d gladly look at it. A lot of the information I find on casual searches seems outdated…or at least older.

tmpfs /dev/shm tmpfs defaults,ro 0 0

there’s the problem: /dev/shm is mounted read-only, which is basically useless :wink:

change the “ro” to “rw” and all will likely be well.

I changed the read-only flag to rw…however, I’m still getting the same error message.

I’m about to do a clean 8.04 install, but I would still like to know what the problem actually is, and how to solve it. I’ll try a reboot…maybe it is still mounted as read-only?

Later…yep, a reboot took care of it, and mounted the stuff writable. Runs like a top. Thanks!