Cannot recover project

I have been working on a track for a while and it had heaps of sends to a few busses for effects.

Everything was fine until I decided to rename the sends to a description of what they were sending to (think creating a space with subtle reverbs and echos).

Suddenly, the project wont start, ardour crashes telling me something about how the name of my send already exists. I guess ardour can’t handle multiple sends with the same name across multiple channels.

That’s okay (sort of) except - why can’t I recover my project and fix it? I have snapshots, but they were taken before I did some important tracks, and now those tracks aren’t even available in the regions list.

Does anyone know how to recover a lost project like this who might help?

I’ll have a hack and if I find a way, I’ll post it.

From checking the directory, the *.ardour.bak file has been updated with the same date as the *.ardour file and a diff shows they are the same. This means to me that by trying to open the project, the last good version of my project is lost… I’ll stuff around some more…

Nope. I tried editing the .ardour file by hand, but I either don’t understand the schema well enough, or there is some dependency outside the schema I am missing.


Get on IRC ( and people will be able to help you.

When is a good time and in which timezone? I don’t seem to get anyone on there.

US Eastern is my timezone, but its generally fairly “busy” from the middle of the central european workday to the end of the US Pacific workday.

I did the same thing. I wish ardour would balk when you tried to name two sends the same.

I went into the xml file and removed all the sends and the project opened just fine.