Cannot open LV2 plugin GUI

Hello. I used to work with ardour 2 and 3 on linux, and now I am trying Ardour 7 and 7.1 on windows 10.
Everything seems to work fine, except that whenever I try to add a plugin to a track, if it’s a LV2 plugin, then trying to open the GUI to configure the plugin ends with a crash (the window does not respond).
Do I have to install something special to make my LV2 plugin work ?
Thanks in advance for the answers.

Should work, but where did you find an LV2 plugin compiled for Windows? LV2 was developed on and for Linux, and although hosts with Linux heritage like Ardour would still support LV2 on Windows (I think, may need to double check), I have never seen a Windows plugin offered in LV2. It would be possible, just seems the demand would be very low compared to a format which can be used with other Windows software such as VST2 or VST3.

At least DragonflyReverb, zam-plugins, disthro and supposedly Robin’s x42 plugins are offered as LV2 for Windows.

If this pertains to some for the ACE-plugins that come with ardour (ACE-EQ, ACE-compressor), this could be caused by outdated graphics drivers.

Those plugins use openGL for the custom GUI.

It comes up occasionally on Windows and is usually solved by updating the graphics driver.

Makes sense, those plugins have a linux heritage as well. Hopefully updating the driver as Robin suggests solves the problem.

I don’t think I can update the driver. It’s a very old dell computer from 2007 and the graphics card is an ati X1300. Are there other options ?

That card is still supported by Mesa on linux, if switching your machine to a linux distribution is a consideration.

You vanished from IRC before I could continue… My fault I had to drive my wife to work. Anyway, if you right click on the the plugin, a context menu opens (drops down) and at the bottom there are two buttons, Edit (don’t use that one) and “Edit with generic controls”. Try editing the plugin with the generic controls. If this works for you, it may be a way around looking for a new graphics card.

You may also want to go to edit->preferences->plugins->plugin GUI and deselect all three boxes so that the plugin GUI does not try to open when you add it to a strip.

That last trick (edit with generic controls) works perfectly. Is there a way to change something in the preferences so that double clicking on the plugin opens the generic controls GUI instead of the openGL one ?

I looked through the preferences for that while I was looking for the
“don’t open the gui on insert”. There does not seem to be a setting for
generic controls to default that I can find.