cannot load error

I am running Fedora Core 6
I had installed Ardour 0.99 using yum
When i clicked on the icon to load nothing happens.
So i decided to run ardour from the terminal.

I get the following error message:

$ ardour
ardour: error while loading shared libraries: /usr/lib/ file too short

I am still fairly new to linux, and dont know what to do!
Please help


try typing ‘locate’ in a console to see if the file exist and where it is located.
perhaps you first run ‘updatedb’ as root, and than locate…


Ok thanks, when i run locate i get the following



so it appears the file is there
what else can i do?


yeah, and it is at the expected place…

perhaps you do reinstall libcurl and libcurl-dev?

other, try running ldconfig as root.


You might also want to check if there’s enough free space on your drives. Maybe use “df” to check that.

Because it looks like the library is corrupted, reinstalling with enough free space might help.

One strange thing is that the library is also in your home directory where it doesn’t belong to. You could try to create another user account, reboot the machine and login with the new name and try to start ardour.

I dont know how to reinstall libraries…a push in the right direction would be greatly apreciated.

since i dont know how to install/reinstall libraries i did try ldconfig…and command was not found.

I do have enough space on my computer though,

$ df
Filesystem 1K-blocks Used Available Use% Mounted on
7935392 4288244 3237548 57% /
/dev/hda1 101086 15986 79881 17% /boot
tmpfs 224572 0 224572 0% /dev/shm
85637472 10473664 70743408 13% /home

I will try to make a new username and run Ardour from there…
I’ll post my results when I’m done.

Thanks for the help and I greatly apreciate it.

OK well i tried to make a new User and run Ardour.
I still got the same error.

I will try to figure out how to rienstall the library…

If anyone knows what i can do to get this running i am open to suggestion.

Once again thanks for the help, and if you all know any place where i can get an explanation on insalling libraries that would be great.


for it to happen faster, try asking in some red-hat based forum/mailinglist.

it is really not normally that you have in your home dir, i think too!

you could give the red hat people the same error report as you made here.