Cannot load Ardour5 Project on Ardour6

Is there any tool for converting from Ardour5 to Ardour6 format?

I am getting the following SEGFAULT when I try to open it:

Could you upload the “*.ardour” session file? That may provide some clues, and perhaps allow to reproduce the issue.

Also, does it work if you’re not using JACK, but stop jackd and use Ardour’s ALSA backend?

Another thing you can try is to enable “Safe Mode: Disable all Plugins” in the recent-session dialog.

Safe-mode does nothing =/
Also tried with -no-connections, nothing changed.

Ardour automatically goes for JACK, how can I choose ALSA instead?

I actually just solved it by installing ardour5, opening the backup version, deleting one weird MIDI Bus I had there and then saving it again. Ardour6 still says that could not find the MIDI files (and actually deletes them), but I had a backup, copied them over and then it worked.


If jackd is not running, the Engine Dialog should show when open a session.

That’s good to hear!

It would still be useful to know why it failed. Ardour should be able to load and convert old sessions. There have been a few edge-cases in the past that caused issues, and ideally those would be fixed.

Maybe the 5->6 conversion fails on UTF8 path names
“Loading /mnt/Δεσποινα/Musical/Studio/SF2/general/CT8MGM.sf2”

The conversion which worked still contained the same path. Everything I do have weird paths like that, tbf.

Also a piece of trivia, the last time I’ve had any problem related to UTF-8 on Linux was early 2000. I couldn’t say the same about Windows though :stuck_out_tongue: All in all, I doubt it could be anything UTF-8 related.

I think the problem was a Bus which had previously been connected to my MIDI Drumkit. It actually shows in the output (should it?) along with several “could not connect” messages.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.