Cannot install on Linux Lite

Hello group…

I have recently discovered Ardour and have been experimenting with it for my future home studio use. I had no trouble installing it to my xubuntu desktop computer by simply double clicking the file. Everything installed fine and works great.

So, now I am trying to install to a freshly loaded Linux Lite laptop. Double clicking the file did not work…so I tried the terminal approach by opening a terminal in the directory where the tarball file is located and typing ./

For whatever reason, it refuses to launch the installer the way it did in xubuntu and give me this error message…

./ 25: ./ /home/kenneth/Ardour_32bit-3.5.143-dbg/ Permission denied

I had no trouble loading the repository version from the software center on this system, but this is obviously a much older version and the newer version is simply amazing so far.

Any thoughts??? Thanks in advance…


permission denied means either you are running it as a user that does not own the file, or the file does not have permissions to execute.

Right click the file, go to properties, them permisions and check that the permissions check box is checked,. then try and run it again.

The install script is typically not executable. The instructions in README tell you to run sh ./ We don’t rely on it being executable because some systems interfere with this in odd ways.

sorry i totally misread the post, the script ran fine but it couldnt run the 2nd part .

Ive had this before. couldnt work out why so i downloaded a fresh copy and it installed fine.

Thanks everyone for the info.

I double checked the permissions and they looked the same as the other computer. Made the executable as well…still no glory. However, I started discovering that the laptop also has issues with running JACK with the built in sound card…common issue after a little research. This was also confirmed when I tried loading AVLinux on the laptop and JACK failed to operate…Ardour threw errors about JACK not running correctly. AV Linux seemed to run fine and extremely fast, but the audio side just failed to work out.

So…I am going to bail on the laptop and just continue working with the desktop, which worked beautifully.

As a side note, I noticed the AVLinux forum does not allow any new registrations and could not find a way to contact anyone…curious if anyone knows why?



Odd, Glen from AVLinux posts here fairly regularly, maybe he will be able to comment on that.



Sorry we had a major problem with Spammers over the holidays and a failed forum update on top of that so we disabled registration until the mess was cleaned up, I hope to have registration re-enabled very soon, I’ll post here when it’s up again.

Apologies for the inconvenience…

Hi Glen,

Thanks for the update…and sorry to hear about the spamming problems. I will wait patiently for the registration to come back online. Thanks.


Forum registrations have now been enabled again, please feel welcome to join and again my apologies. Spammers ruin things for everybody… :-/