Cannot get cut 2/2 time signature to show proper # of measure

Forgive the silly question from a beginner: but I cannot get the ruler to show the proper number of beat for a cut time baroque piece I’m working on.
It’s a kind of lament, in 2/2, with a slow tempo of half note = 42.
I imported the audio track, then set 2/2 for the time signature in the ruler, and 45 for the tempo in its own ruler. Yet, bar/beats ruler shows half the piece’s measures. If I adjust the tempo manually from the ruler to make it coincide with the actual beats, the tempo is doubled. It seems the time signature is 2/2 but the tempo must be entered in quarter notes?
There is obviously something I’m missing here

Edit > Preferences > General > [ Allow non-quarter note pulse ] perhaps

Thanks Paul! That was it