Cannot get any version of Ardour to open


(Jaredloomis) #1

System info:

All versions behave the same on my system: I see some initialization logging in console. That’s it. Process doesn’t end, resources aren’t used excessively, no error log, no GUI. Here is the console output

bind txt domain [gtk2_ardour5] to /usr/share/ardour5/locale Ardour5.12.0 (built using 5.12 and GCC version 7.2.0) ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files ardour: [INFO]: Loading system configuration file /etc/ardour5/system_config No protocol specified ardour: [ERROR]: ** ERROR ** VSTFX: Failed opening connection to X ardour: [ERROR]: could not initialize Ardour. No protocol specified

(ardour-5.12.0:2504): Gtk-WARNING **: cannot open display: :0

More diagnostic:

[username@arch ~]$ ps aux | grep Xorg username 693 0.8 0.4 518664 71812 tty1 Sl 15:09 2:59 /usr/lib/xorg-server/Xorg -nolisten tcp :0 vt1 -auth /tmp/serverauth.glOTKd0Osk $ echo $DISPLAY :0

(Peder Hedlund) #2

Problems with distro specific versions shoud usually be discussed on the distro’s support forum.
That said, it seems to be a problem with the linuxVST you have, maybe it’s compliled without X support?
Try startting ardour with the -d flag, to disable plugins, and see if it starts.


(Jaredloomis) #3

@peder - it’s not a distro specific version; I was mentioning how I installed. It’s unmodified official source code. I started the process with -d, no change, then tried “ardour5 -a -d -n -O -S” (turning a bunch of stuff off), still no change in behavior.


(Paul Davis) #4

If you built ardour’s master branch, you built 6.0-preX. This is a totally unstable, unsupported version.

If you want Ardour 5.12, you need to ensure that you first checkout the “5.12” tag.

We do not ensure that the ardour master branch corresponds to the last release. Unless you are actively testing features under development, you should be using the last release.


(Jaredloomis) #5

@paul - as described in the post, I built 3 different versions in order to try to fix this, obviously starting with the latest stable release. Third line of the post…


(Paul Davis) #6

You said that you got the source from Ardour git. A regular clone of Ardour git will NOT give you the latest stable release. You must use git checkout 5.12 before building.

The error output you showed comes from a version that wasn’t built at ardour.org, which means that we do not officially support it.

Finally, as noted, this error looks just as likely to be related to a plugin as to Ardour itself.


(Mikael Hartzell) #7

Could you just try the supported version which you can download here: https://community.ardour.org/download

This is the only version that is supported. Source / binaries from any other source is not, so it’s best to start debugging with the official version.


(mike@overtonedsp) #8
..this error looks just as likely to be related to a plugin as to Ardour itself...
If I remember correctly from back when I added the VST stuff, I think

ardour: [ERROR]: ** ERROR ** VSTFX: Failed opening connection to X"

Is the VST hosting code trying to establish a connection to the X server rather than a plug-in trying to do so. (Some plug-ins instantiate their own connection to X to render their GUI, some don’t, so the host (GUI) code establishes its own connection - then the plug-in GUI is reparented into the host X Window which in turn is embedded into GTK). So, its not necessarily a plug-in which is at fault, more a general issue with failure to connect to X. The GTK Warning

(ardour-5.12.0:2504): Gtk-WARNING **: cannot open display: :0

would seem to back this up. If possible it might be worth trying opening some other X dependent application (e.g. xterm? ) and see if that works