Cannot draw notes on MIDI region with the pencil tool

I recently installed Ardour 7.2 and recorded a MIDI track in percussive mode notes.
Now I cannot draw any notes with the pencil tool on it. The Note shows up under the cursor but as I left click it disappeares and no note is drawn.
Moving existing notes recorded from my MIDI drums works perfectly fine.

What am I do wrong?

1 Like

May be your grid duration is on the Bar mode? If so - just choose 1/4 or less note mode.

Thanks for the hint but it did noch cut it: I had the grid set to 1/4 already.

Further try/error showed, that I can draw notes with the pen but NOT in percussive mode. Plus: when I switch to normal mode the percussive notes recorded before are not visible…

Is that a candidate for the bugtracker?

May be//
But interesting to figure out first…
Is you Ardour official built or repo or built yourself? Sometimes Ardour from repo or self made build (recently I’ve built successfully my own) have the different behavior from the official build.

This can happen if the notes have a very short length (while the percussive record) - may be try the rectangle selection all notes in the percussive mode> then right mouse button click > then choose Transform>set: length - to exactly - 0.20 (for example) - this will make all the super short notes longer and visible in the sustained mode.
percissive_usual_length

EDIT: Also interesting to figure out when Ardour decides to record super short invisible notes. When I record - I can’t find the condition for “invisible” notes recording.
(in my previous gif example I’ve made invisible notes by manually dragging the end boundaries to the start of the notes):
making_invisible_notes

1 Like

Yeah, I think, working with sustain mode notes could be my workaround as well… but then I just deleted the region and recorded a new one and drawing notes in percussion now works as expected… :robot: :face_with_raised_eyebrow:

Ok, I will watch that …

BTW: nice collection of GIFs you seem to have here… any chance to find these and more somewhere on the interwebs?

1 Like

I make my gifs just for this forum - they are all in my posts here.)) I use peek program in my Ubuntu 22.04.

If you are in Ununtu too - you can install it through:
sudo apt install peek

In my case if I launch the peek through
peek_launcher
standart Ubuntu launcher - this does not record the mause cursor. So I use the terminal with the command: peek -b ffmpeg - and this records the gif with the mouse cursor including.

Also I use Vimeo to do my long video help (with the sound perhaps in some cases).
An example:

2 Likes

)) A peek-record of a peek-record:
:alien: EDIT:)) double better version:
peek_record_of_a_peek_record

2 Likes

Similar trouble again:

When I split a drum region , i got a note set on the first slice magically appear on the second, so I select all regions then break the connection between them and now I can again not draw new notes on all of the cuts though I can edit existing notes(drag them, delete etc…)
I can whatsoever draw notes on some of the new regions.
Below we see 2 Regions in 2 tracks.
I can draw in the upper one, in the lower the Note square and name is shown when I hover with the pencil tool but not drawn at left click, left to bar 103, right to 103 no square/name at hover and no draw.
Note, that these are exactly 2 regions, there is no cut at 103…

As before this only occures in percussive mode, sustain mode works as expected…

I too have problems drawing percussive notes If I shorten then region. If I just create a region and draw in it it works fine but if I cut or drag the region making it shorter then the notes seem to fall behind the pointer by the same number of beats that I cut from the region.

I made a little video as every gif I made with Peek was too large to post.Percussive MIDI Weirdness

2 Likes

Exactly the same with the video support! :drum: :

I make so much bug-reports and feature requests currently. …and began to understand how much information is going to the 2,5 developers! :hotsprings: We must be patient, people!
…Good mode to programmers!
Ardour is a power!!

1 Like

That’s why I make a little record region for peek & super-fast minimal actions. But this situation requires a video record, so I use Simplescreenrecorder:
https://www.maartenbaert.be/simplescreenrecorder/
I’ve noticed if people use a video support here - the time of the understanding minimizes drastically.
Thanks!

I recorded with simplescreenrecorder first then tried to make a gif with
peek and ffmpeg. Both were too large so I just linked the original video. I
need to look at my Peek settings.

Perhaps 0009234: Can't draw notes in percussive mode - MantisBT ?

1 Like

my peek preferences:


I use peek only if my screen-cast time not more than 10-15 sec and also the resolution is about 800x300 or similar. You just need to train the record different variants of resolution&time combination and look at the rendered file size.

Hi, Robin! Is it possible to test in Nightly build already? (I mean I’m able to download v7.2.267 now) Thanks!

1 Like

Ardour 7.2.270 should be up sometime in the next 10-14h

2 Likes

(Ardour 7.2.267 has the same bug behavior - tested) :))

1 Like

Aside from the bug mentioned above

This happens when you click and drag the mouse. To enter Percussive hits, only click without moving the mouse.

1 Like

Trust me: I tried every way and style to draw that note… :wink:

That bug looks very similar, good to hear, that it is fixed already for the next release…