Cannot configure Latency


I start a new session using ALSA, I record the metronome on a new track to check recording latency. and I see there is latency:

I cannot see where I can adjust for that figure. I can do it in Audacity, but not in Ardour.

I know there is a Callibrate option when you open a session. But that is not working for me. It seems so close to working, it is actually measuring the latency ok but it never allows me to “Use results” and there is a ‘bad wiring’ message in one of the measurments:


SO I thought, “well I don’t mind if this jack_delay program is failing, I can just measure and set latency manually like I do in Audacity.” but ALAS, once the session is opened there is no setting that I can find to adjust for latency. Am I missing something? Is that possible?

Some details:
I am recording through my Voicelive3 Extreme using a USB connection to my computer.
I am using Ardour 5.
In the Audoi/Midi setup I choose

Input Device: Voicelive3
Output Device: Voicelive3
Sample Rate: 48khz
Buffer Size: 256 Samples
Periods: 2
Input Channels: all available channels
Output Channels: all available channels
Hardware input latency: 0
Hardware output latency: 0
Midi System: None

Maybe I should just set Hardware Input Latency to what I measured using the metronome record. Is that right? But is there any way to do that without 1- record the latency 2- quit session 3- open session and set Hardware input latency?

I am also interested in why the callibrate function fails for me, but I imagine there are a lot of variables at play there.

You can instead enter some values manually in the “Hardware input/output latency” fields.


but you first have to establish what those are. One way to do this manually is to record the metronome like you did. Then look at the difference.

(You can change ardour’s clock to “delta mode” and show “samples” (right-click on the clock display).

As for measuring it using the calibration tool: Have you used a cable to connect output -> input to measure it? If so perhaps there’s excessive gain (turn down the volume). or were you using speakers & mic?

Hey thanks so much for the fast reply. I tried that just now and I can’t get it right but I see it is having an effect.

If I have this measurment with the metronome record, what number would I put in the input and output latency:

I have tried a few things, but this is where I get confused. My Voicelive3 is both sending audio to the computer and receiving it back from the computer. via the usb connection. I don;t know where I would connect a cable from and to. I tried a few different things, like my headphone out from the voicelive3 to my computer mic in. And also using a speaker, but still I get the same problem.

thanks for the delta tip

oh and I tried turning down the signal from my Voicelive 3 USB output and still get the same problem

Right-click n the 2nd clock and change it to “samples”. calculating this using Bar/Beat is … tricky.
probably something around 1980 samples

Then put half of that as systemic input and half of that as output latency e.g

Hardware input latency: 980
Hardware output latency: 980

That’s rather long though… but not too unrealistic.

Ahh thanks, it’s measured in samples!! I would not have worked that out without your help.

I measured the difference in samples again at 2968 (thie first one I mentioned was incorrect)

I tried input output half but it was way off.
So I tried input 2968 and output 0 and it was very close.

I could not get it exaclty right with 0 output latency,

So I tried input latency 2468 and output latency 500 and that is nearly perfect now.

But now I realise my settings were a bit optimistic with low sample rate as I am getting the x*___ (forgot the word… xread or something) clicking sounds. SO now I have to start all over again.

So I tested twice using 0 latency configuration and my metronome in the same session reopened twice,
seems there can be a big difference in latency when you close ardour and reopen it in order to adjust those latency variables. 2100 samples then 3200 samples, so it seems for manually setting the latency you need to be lucky to get it right.

Have I misunderstood something though? DO I have to shut down Ardour and reopen the session in order to adjust those latency variables or is there another way? Would be much easier if I could adjust them within the session? Maybe that involves stopping ALSA and maybe that is not permitted.

Ok so I have worked out a reasonable solution for my situation.

If you cannot get the Callibrate Audio to let you Use results because the button is disabled and there is a bad wiring message but you can still run the Callibrate and see the results on the screen. (see image in original question)

Then all you need to do is run it, and use the number from the Systemic Latency measurement, and then click “Back to settings (ignore results)” and add that number to the Hardware input latency.

But then you need to Stop ALSA (button top right in Robin’s first reply) (which starts automatically it seems when you click Measure in Callibrate) and then click Start. Otherwise that setting is not applied to the session when it opens.

It is not perfect because stopping and starting ALSA can change the latency measurement, but it should be close enough.

If you’re using Ardour/ALSA backend (not JACK) then no. That is explicitly designed to allow to calibrate and change latency while running.

(Except when manually entering numbers… Arodur 5.12 didn’t pick that up, this was fixed and Ardour 6.0 does.)

With USB devices, yes. it’s not usually this large though.

see also


ok, so that is why I cannot manually adjust latency without restarting Ardour 5

If I find my workaround is not good enough I will download Ardour 6.

Thanks for the links, interesting reading.

The latency compensation requires connection between the analog in and out of the interface. The VoiceLive-3 is a little different than a plain stereo in and out device, but I expect the connection which would make sense is to use an XLR female to 1/4" (6.3mm) TRS plug to connect the L(mono) output to the line input. You might be able to use XLR female to XLR male if the XLR input can be set to line level. I have not downloaded the manual, so I’m just guessing at whether the XLR input is only mic level and the TRS input is line level, or whether the XLR input can also be switched to line level.

The latency measured that way may or may not be the same as the latency through the guitar input and output, and may or may not be the same with internal effects turned on or off. The complexity of that interface makes understanding the exact behavior with all the possible combinations very complex, but I would start with the connection I described.

Wow, Thanks @ccaudle . You and @x42 have gone way beyond what I expected from a forum. Hats off to you.

I will give it a try and report back. Is there any danger of (excuse my ignorance) setting up a loop that keeps amplifying itself? and doing damage to anything. I would guess not as you seem pretty knowledgeable, just thought I’d check though.

Seems fine, I have tried using the XLR from L(Mono) to XLR Mic/Line input and it does not work and I cannot find any setting to make the Mic/Line input use Line only when an XLR is connected.

So once I find my XLR to TS adaptor I will try that.

The manual indicates there is a menu option to set the XLR output to mic level instead of line level, that may allow XLR-to-XLR to work.

Not if you don’t route the input signal back to the output in the software. It is obviously not a useful configuration for normal use, so you just have to make the analog connections, run the calibration, then put the analog connections back where you need them for recording.
I have not looked at the details of the latency configuration in a while, it is pretty straight forward with a simple stereo in and out interface like I use, perhaps there are so many routing configurations available on your interface that Ardour is not using the output or input that you expect. I don’t have an interface with multiple inputs and outputs to choose, so I’m not sure how you would make sure that the calibration is using the correct output and input.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.