Cannot ADD GUITARIX.vst3

wanted to install the guitarix .vst3 an got the following error:
[ERROR]: Could not load VST3 plugin ‘/home/didi/.vst3/Guitarix.vst3/Contents/x86_64-linux/’: /lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.30’ not found (required by /home/didi/.vst3/Guitarix.vst3/Contents/x86_64-linux/

Ardour on
AVL-MX 21.3

need help, new LINUX user!!
Tipps for DUMMIE, please!!
Thank you!

Possibly the guitarix program was not compiled properly. Where did you get the plugin? I don’t remember if plugins are supposed to statically link libstdc++ or not, I will have to look back at Robin’s notes on plugins, but usually when a plugin has an error loading a library it is because the host OS or application is linked with a different library version, which is why plugins are supposed to be statically linked and fully self-contained.

I downloaded the zip file here:

This looks like it may be hard to build with static linking so that it will work reliably across different distributions and different Ardour versions. From the readme file:

On debian based systems the following packages been needed:

  • libfreetype6-dev
  • libglibmm-2.4-dev
  • libglib2.0-dev
  • libsigc+±2.0-dev
  • libfftw3-dev
  • libsndfile1-dev
  • liblilv-dev
  • libboost-dev
  • libstdc++6
  • libc6-dev
  • libgcc-s1
  • libasound2-dev
  • libgtk-3-dev
  • libavahi-gobject-dev
  • libavahi-glib-dev
  • libavahi-client-dev
  • libeigen3-dev

Are plugins allowed to access the network stack? Not sure why a VST3 plugin needs an mDNS library.

The plugin appears to be compiles against a quite recent libstdc++ and won’t work on your AV-Linux version.

If I run
strings /lib/x86_64-linux-gnu/ | grep GLIBCXX_3\.4\.
on my Ubuntu 20.04 I only get as high as GLIBCXX_3.4.28

You should ask brummer to release a version compiled for Ubuntu 18.04, or at least 20.04

I doubt plugins should be statically linked against libstdc++.
But binary ones should be compiled against fairly old versions, if they’re supposed to be used by as many people as possible.

I’m not sure if they’ve upped the baseline to 20.04 by now but VCV Rack, for instance, had a rule that plugins should be compiled against the Ubuntu 18.04 libc.


In laymans terms AV Linux 21 is a bit old to run the requirements of the guitarix VST3 Plugins release, this is a bit odd especially from the developer of guitarix because he is usually very good at supporting ‘older’ libc6 versions, hopefully as @peder said he will do a release to support older libc6.

In the meantime I will mention if you are an AV Linux user you already have all of the guitarix LV2 Plugins as well as many of the optional ‘gx Plugins’ (and even the new Tonetwist ones!) so those are already there, to my knowledge the VST3 ports are much of the same DSP simply in a VST3 format instead of LV2 and Ardour supports both…

Frst of all, THX for your helpful replies!
Even if I did not understand all of it!!
@ Glen.
well I tried the live version of AVLmx 23.1 and could not get connected to my WLAN, so I decided to not install it because I was very happy with the 21.3 an Ardour 8.2:
But I think I will take a snapshot of my running system and give it 23.1 another try!!

THX for all your help!


In case you didn’t notice there is a ‘Connman’ PDF file on the Desktop of the AVL 23.1 when booted live and it gives detailed instructions for troubleshooting WiFi issues with Connman (the wifi supporting application). WiFi usually just works OOTB but on rare occasion it needs a bit of extra setup and that’s what that doc is for. Also the AVL 23.1 release Video also touches on how to get WiFi working.

I think I missed it!
Will check!!

Some (evil?) plugins “phone home” for various (nefarious?) reasons. Others, like guitarix, can download presets from the public “shared presets” location.

The guitarix binary is build on a github service. It use Ubuntu 20.4. That’s the lowest possible runner github provide. If they would provide a lower version, I would use it.

Yep. Guitarix didn’t call home.

In that case you could consider one of the options offered here:

@x42 Thanks for the link, my answer is more in general than to you.
Well, given that Ubuntu 18,04 is now nearly since 1 Year no longer supported, and that guitarix.vst just gets it’s first release, it looks to me as a waste of time to going that route.
Also, there is no reason I’m aware of that guitarix.vst wouldn’t build against Ubuntu 18.04.
I do the upstream development and I remember very well the day’s were distributors jumps in and provide the binaries for the folks. I missed that. :face_with_monocle:
Now I provide binaries for Ubuntu 20.4, just because folks want binaries this day’s.

Currently I’m working on implement support for loading *.nam files into guitarix (Neural Amp Modeler). Have it working on the main application now (self promotion: it’s out for testing in the repository) and will port it to the vst version as next. Should I stop with that and going to build binaries for outdated distributions instead?
However, all that said, I’m open to implement what ever is needed to build on older versions, but, I’m not going to do that just for fun. Give me a error message when you try to build, for example on Ubuntu 18.04, and I fix it. Other than that, bother your distribution maintainers to provide binaries in there repositories, or, build it yourself. (It’s way easier than it looks on the first view)

Hi Glen,

I really missed it, sorry!
I think me stupid deleted it before reading what is going on in there!
Downloaded AVL MX 23.1 iso again and prepared a new LIVE Stick!
I am online now!!
And yes, I watched your Video before twice and it is very helpful (and will be for the next steps) for a user not “under the hood” of Linux like me in generell !
Thanks for your time and your great work!!
greetings from Hungary

1 Like

Maybe you selected the wrong service target or something, because it doesn’t work on 20.04 :

ub2004:/tmp$ cat /etc/*release*

ub2004:/tmp$ ldd Guitarix.vst3/Contents/x86_64-linux/| grep
Guitarix.vst3/Contents/x86_64-linux/ /lib/x86_64-linux-gnu/ version GLIBCXX_3.4.30 not found (required by Guitarix.vst3/Contents/x86_64-linux/ => /lib/x86_64-linux-gnu/ (0x00007ff74cd37000)

ub2004:/tmp$  strings Guitarix.vst3/Contents/x86_64-linux/ | grep GLIBCXX_3\.4\.30

ub2004:/tmp$  strings  /lib/x86_64-linux-gnu/ | grep GLIBCXX_3\.4\.30 || echo GLIBCXX_3.4.30 Not Found
GLIBCXX_3.4.30 Not Found

Perhaps try the following

patchelf --clear-symbol-version  \
   _ZNSt18condition_variable4waitERSt11unique_lockISt5mutexE \

Assuming older stdlibc++ provides a compatible version of the symbol at hand (std::condition_variable::wait(std::unique_lock<std::mutex>&)).

I just checked it and it looks like github added a extra ppa to the runners which introduce the updated libstdc++:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test 

I’ll check if I could remove that before run the build.

The very first thing you should take to heart with Linux: Never download and install any software from the internet! Use the package manager that came with your Linux distro, and you are very likely to find GuitarX in there and be able to install it. The programs in there are made to work with that distro specifically, and even checked to be safe (No viruses, malware…).

Happy Linuxing!

Following very important basics like that will be more secure for one, but you will have a lot fewer problems if you do it that way, until you have enough experience to even consider downloading and installing software from anywhere else but your Linux distro’s software repository without understanding how to deal with incompatibilities and much more. You shouldn’t even download and install a software from the developers git or whatever web page they have unless you know ahead of time it will work with your distro.

GuitariX is so popular, I would be surprised if it isn’t in the repo for your distro, and if you search for it by name, it will most likely show you more than one choice (as app only, as app with plugin version, or just the plugin… and if you want the VST version, select and install it.

These aren’t in any (Debian) Repo yet and are a separate project from the ‘regular’ guitarix… If you are never going to download anything for Linux Audio outside of a Repository you are going to miss out on a LOT of Plugins… The issue here is simply a libc6 mismatch which happens quite often with new Plugins and mature Distros…

1 Like