can’t load module Glaceverb

Hi, I’m trying to use the Glaceverb free vst plugins with ardour, but I get these 2 messages when adour is starting can’t load module Glaceverb and can’t load module yyyy where yyyy is the name of something I don’t remember but it belongs to the same vst plugin.

I heard that Glaceverb might be the best vst free reverb and I’m invoking Ure help to help me realise that.

Platteforme : Pentium 4 3 Ghz, 1 G Ram, Ubuntu Studio 8.04, Ardour 2.8 compiled to use vst=1, wine and wine-dev 1.1.14.

I know some other vst plugins that just make my ardour crash, but with Glaceverb, there is no crash, I get the 2 msgs above and then when I launch the effect from the plugin manager, the Glaceverb interface comes up as it should be but with no effect on the track signal.

N.B: ladspa and some other vst plugins are working good.

Thank you for Ure help.


Although I don’t use GlaceVerb, some VST Plugins create subfolders with extra supplemental code in whatever directory they’re installed in, many of these do not work with FST (the Ardour VST enabling app) even if the GUI launches.

In the meantime until someone with better GlaceVerb knowledge comes along, have you tried Ambience Reverb by magnus or the ANWIDASoft DX Reverb Light, both work well with FST and are highly rated as well.

Sorry GMaq, I couldn’t check the forum lately,
I Thank U so much for Ure interesting reply,
I will check these to links and let U know.

I hope they sound better than the ClassicReverb vst or the Ladspa Calf reverb,
these are yhe only ones I can deal with, since all others plugins sound a little fake.

Thanks again Gmaq.

I’ve just tried GlaceVerb using my standalone jack-client VST host, works fine, but when you run GlaceVerb, it creates a ‘GlaceVerb’ folder in the directory in which the .dll resides and dumps some .SEM and .SEP files in there. This is normally an indication that the plugin has been made with synthedit. Synthedit plugins need to dump the synthedit modules they are built with / use (.SEM files) into a folder on start up. Perhaps the VST host part of ardour (sorry - not sure how that works) is getting in a tangle because of this?

Thank U linuxdsp,
What is Ure standalone Vst Host, FST?
According To U Glaceverb needs to write some files in the plugin directory,
since ardour runs in simple user mode it won’t allow any writing commands in the /usr/local/lib/vst wich is the ardour vsts path.
Now I will try to run ardour as root, and i will see! even though ti’s a bad habit to run under root. (mistakes can happen!).
Any way I will give it a try and let U know.
Thanks again.

My linux VST host was something I wrote myself, I am hoping to be able to release it soon - I already have some plugins (jack clients) which you can find at they’re free to download. I haven’t released the VST host yet because of Steinbergs SDK licensing policy. In any case, I think its better to use native linux plugins where possible - and be careful if you run applications as root - I’m sure you are aware of the risks! Perhaps there is a method for putting the VSTs somewhere you can safely write to as a normal user or perhaps you can change the permissions on /usr/local/lib/vst as an alternative to running as root. I’m not very familiar with using VSTs in ardour. I should learn about it - but I prefer to use native linux plugins and run risky things like windows VSTs outside of the DAW.

I have some VSTis (and a fortiori, it would be OK for VSTs) in /home/myself/vst
*replace myself by your username of course :slight_smile:

you can have the VST_PATH environment variable set up to point to this path.

In your home directory, edit the file .bashrc (if you use the bash shell by default) and add this at end

# VST path export VST_PATH=$HOME/vst

close the terminal
open up a new terminal and you should be good
create a directory called vst in yourhome directory, move all your VSTs from /usr/local/lib/vst to this directory
start ardour again from the new terminal

see what you gonna get

Hi again All of U,
Hi thorgal, well In fact, that’s exactly what I was going to post as a question now ! :
How can I tell ardour about a new VST_PATH, (I’ve never did it before).
And U “throgal” simply were in advance, and U got it right!

In deed, It worked just fine running ardour as root : Glaceverb and other that refuse to launch, went just fine. (thanks to linuxdsp who inspired me)

And I thank U throgal for showing me how to alter the environment variable, before I even ask?.

<<<<<<<<<<<<< It is just working fine !!! >>>>>>>>>>>>>>

Thank U so much, All of U.
And Thank U GMarq for the alternatives, they are such good vst plugins what U mentioned. (now I have them and I will Use them thanks to U).

Some Body Tell me How To mark this Topic “Resolved”.

Thank U.