Calf Multi-Band Comp not playing nicely with Ardour 3.x?

Not sure where to go with this since I don’t know who owns this issue. I had been running A3.2 on AVLinux 6.0. It seemed like Calf MultiBand compressor was using way to much CPU when the gui was up - no issues w/o the gui. I figured it was because of my compass settings and perhaps one too many tweaks . . .

In any case, I re-built my system with AVLinux 6.01B. I put A3.3 on and left the AVLinux builds as well (a really late 3.1 build, I think). Now it seems, if I leave the gui for Calf compressor up for more than a few minutes, something bad starts happening and I can watch CPU usage gradually go up until audio starts dropping and the whole thing locks up in some kind of weird state. No problems as long as I don’t bring up the gui for more than a few minutes.

I’ve replicated this several times, both with the AVLinux build and the fresh 3.3 build. Also, the version of the Calf multi-band compressor is about the 3rd or 4th version I’ve seen recently, it seems. This version adds the visualization of the filters.

When the system gets into this state, I can watch a system monitor as see very high CPU usage from Ardour even though nothing is happening (playhead stopped, no sound, etc).

Any ideas? If I had to guess, I’d say the version of Calf Multiband compressor packaged in AVLinux 6.01B is problematic but I don’t know. Other factors changed at the same time (A3.3, AVLinux 6.01B).

Hi Aaron, i´ve seen some CALF (git)plugins to be much more CPU consuming than others like LinuxDSP or Invada, that have improved over the time but multiband compressor is still quite processor consuming, i guess there is some work yet to be done by the developers on that plugin, however i bought the Mastering suite from LinuxDSP when i bought the Mixbus 2 License and those plugins are very light on the system resources, and very good sounding also, would be great if the were more graphical and had a few presets to play with, but they´re very very nice. Try them!

Thanks fernesto. Yes, I looked at the LinuxDSP plug-in. Looks like there is no visualization of the compressors. If I had more experience, training, better monitors, etc, I wouldn’t need the visualizations . . . but I don’t ;-). I don’t remember seeing a multi-band compressor from Invada.

I have a conversation going in the mailing list on this issue. I have some other versions of Calf that I am going to try. It may be just that the version of Calf the AVLinux guys packaged has an issue, at least with my hardware.

Teliasopia have 5 band compressor with some visualization.
Maybe I try it my self ?


As has been mentioned the Calf set really varies from fully developed to still quite alpha and even in a best case scenario the CPU optimizations also vary. I am currently on summer hiatus but will try to have a look at building an updated Calf package soon. This is the first problem report I’ve had on them. If you are comfortable with a compiler AV Linux comes with all the build dependencies installed to build Calf and if you install to “–prefix=/usr” it will cleanly overwrite the existing package files.

GMaq - I’m afraid I’m a bit of a noob and not quite to the point where I feel comfortable building from source. A good part of what I know about Linux came from reading your AVLinux documentation - which is brilliant and incredibly helpful, I must say. I am certainly capable, however, and, if it would help you, I will do some homework, get comfortable with building from source, do it, see if it works, and report back. Let me know. . .

OK. I found some time to work on this tonight. Here’s what I did:

  1. attempted to build the latest stable Calf release from source. Got errors. Since I don’t really fully understand this process I stopped and didn’t go to the install step.
  2. installed the older AVLinux package I had stored dated September of 2012 since I thought that had worked when I had 6.0 installed. Same issue, however.
  3. turned on the task manager and noticed Conky using pretty much CPU (>10%). Thought that was weird so I turned it off. Left the task manager on so I could see what was going on
  4. started over, this time watching the task manager, with interesting results:
    With Compressor GUI off, A3.3 was using about 10%, Xorg 1-2% during playback
    Turn on compressor GUI and Xorg CPU jumps to around 50% but Ardour stays at about 10%
    Leave the GUI up during playback and in about 5 minutes CPU for Ardour starts to drift up but Xorg is steady at about 50%
    Once CPU for Ardour reaches about 30%, all heck breaks loose. Gaps in playback is a sign that it is all over. When that happens, you can stop the transport, close the compressor GUI, but Ardour is still chewing on something, continue to grab more resources, and in a few minutes will be locked tight.

Thats odd i have no problems using calf eq or compressor plguins i don use the multiband, the normal compressor works fine. it is resource intensive but once the gui is closed everything is fine, i dont ever get glitches in audio playback.

Im running kx studio and it is by far the best distro i have tried yet, it has jack setup pretty much out the box and i have even managed to get latency down to 11ms without any x runs which was impossible on ubuntu studio.

As for compiling from source, the errors are most likely due to missing libraries required to build the software.

For all versions:
autoconf and libtoolize for the build process
glib 2.0
Expat XML parser
For GUIs (JACK, LV2)
GTK+2 headers (2.8 or newer)
libglade2 headers (2.4 or newer)
Pixmap GTK2 engine
For LV2 plugins
LV2 core package >= version 6 which means package version 1.0.0 (available in recent distributions)
For JACK GUI application (calfjackhost)
All libraries required by the GUI above (you cannot build a GUI-less JACK client version)
JACK audio client library (0.105.0 is the minimum version, >= 0.109.2 is recommended)
Optional: LASH client library 0.53 or newer, for session save/load support

I dont know how packagtes are managed in av linux, with debian bases systems usually use synaptic and search for the packages and install them along with the -dev packages

Thanks Veda. Since the Calf version packaged with AVLinux appears to be newer than the ‘stable release’ version available from SourceForge, I had assumed that all the libraries would already be there. I will dig into this when I get a chance. And yes, no problems from any other Calf plugins. Also, no problems with the multi-band comp if I keep the GUI closed. . . which is normally the case anyway.

Maybe it’s my inexperience . . . but I don’t understand how Ardour can display a very intensive visualization of the mixer, meters, tracks, etc and only drive 1-2% CPU usage in Xorg while the GUI of one plug-in can drive Xorg to need 50% of my resources. The GUI of the compressor does not seem particularly more or less graphically intensive than Ardour itself.


While I don’t know for certain what is going on in the Calf GUI, it cane be more than just the GUI, and just the GUI is triggering it. Also I will say that there is a LOT of optimization in Ardour for what you mentioned, particularly the metering. Nothing is as simple as it first seems;)



Yea, good point! What I am seeing on the task manager is certainly just a high-level, surface view. I was hopeful that my observations would be a clue to someone who knows more than I. Also, the fact that this apparently is not a widely reported issue suggests that the root cause may be related to my particular configuration (HW and/or SW) . . . I’m just not smart enough to know where to go from here.

Thanks everyone for your input. I’m just going to remember not to leave the GUI up and call this resolved.