Buzzing/Clicking in background of recording

Hey All,

I am new to music and recording. When I record my guitar into a track in Ardour I get some weird clicking and buzzing background noise. My guitar has single coil pickups but it doesn’t sound like a pickup buzz.

My setup is like this:
Guitar → Scarlett 2i2 → Laptop
Inside Ardour I create a new track, fuss with the routing until it seems to work, record and play

I have tried redoing it a few times and swapping cables so I think it isn’t the Guitar or cable itself, not sure what to test next.

Can you post a short sample with an example of the noise?

Are there perhaps any audio-dropouts?

Check top-right in Ardour status-bar. Is there a number in brackets after the DSP load like:

image

that counts audio buffer under/over runs (x-runs). If so try to increases the buffersize (Menu > Window > Audio/MIDI Setup).

I am trying to figure out how to share it, but i have a sample mp3 with the noise on it.

It says 0% so I don’t think ive dropped any samples

Upload it to wetransfer and post the link here.

Go to wetransfer.com
(If needed accept cookies, click to “I just want to send files”, etc.)
On the left there is a box, click on the circle with three dots (on the left side of the Transfer button)
Select “Get transfer link”
Drop the file to the window.
Get the link.

Paste the link here.

Thank you!

Do you hear this noise with a headphone connected to Scarlett 2i2 and using direct monitoring (and without Ardour running)? Or it is clean this way?

(My Rubix 24 interface can do direct monitoring even without any daw running.)

Nope I don’t hear the noise with headphones into the scarlett and ardour off.

Great! So we eliminated your guitar and all the cables and the preamp of the interface as the potential source of the problem.

Most likely the problem is with sub-optimal interface settings in the os and/or in Ardour. You can try to increase buffer sizes (latency) and see if the problem persist.

Unfortunately I can’t help you further because I don’t have any experience with Mac and Ardour on Mac.

I’m sure others will help you in checking and setting proper buffer values for your interface.

Thanks, I’ll plug it all in to my Ubuntu box soon and see if it makes a difference.
I will double check the buffer size but I think I set it to the max when I started the session.

If you can post a screenshot of your settings.
Window → Audio/MIDI Setup