Bus Master routing with 8 channel VoiceMeeter


(Zor) #1

I’m using VoiceMeeter on Windows 10, as I’m working on a 8 channel project.
I couldn’t manage to configure the Master Bus routes with 8 channels in order to have the 1st channel of the bus output on the 1st channel of VoiceMeeter, the 2nd channel of the bus on the 2nd Channel of VoiceMeeter, etc…
I’m using mono tracks and want to mix several tracks on each channel, but I couldn’t get it to work with the master bus.
If I route directly each track to the hardware outputs it works (1 channel of each track on any channel of the hardware output).
If I try to route my tracks to the master bus inputs, I have to use the 3rd channel of the track (or sometimes another one, which is weird as I have only mono tracks, so it should always be the 1st channel), and the output from the bus to the hardware is not send on the proper channels of VoiceMeeter, and 2 channels are used instead of one, despite I’ve only checked one channel.
Don’t know if it’s specific to the way VoiceMeeter exposes its channels (it works with Vegas movie studio) and I don’t know what to do to have the routing of the bus outputs to the hardware working correctly.


(Colin M Fletcher) #2

If your tracks & busses have more than 2 outputs, they’ll have a VBAP panner by default. This almost certainly won’t do what you want; you can bypass it by right-clicking the panner and choosing ‘Bypass’. This will make the track or bus signal go to all its outputs, rather than just those that the panner is panned to.


(Colin M Fletcher) #3

Alternatively, you can remove all but one of the outputs from your tracks & busses: that way, they won’t have a panner at all, and you can just connect the single output of each where you want it.

You probably ended up with 8 outputs on each track because ‘Connect track and bus outputs:’, under Preferences|Signal Flow, is set to ‘automatically to master bus’. Set that to ‘manually’, and newly-added tracks and buses will have the number of outputs you choose, rather than the number of inputs of your master bus. You’ll have to then connect them manually where you want them.


(Zor) #4

Thanks ,
bypassing the VBPanner did solve the problem.
However setting “Connect track and bus outputs:” to manual didn’t reduce the number of outputs on tracks, but it’s not an issue.


(Colin M Fletcher) #5

Glad you got it working!

Just to clarify: the ‘Connect track and bus outputs:’ setting won’t change the number of outputs of existing tracks and busses - it only changes whether newly-created tracks or busses automatically get extra outputs to match the number of master bus inputs or not.


(Zor) #6

That’s what I understood, but when I tried to create a new track, having this option unchecked, it still had 8 outputs instead of 1.
I was choosing mono as configuration option when creating the track, I tried choosing custom and I finally got 1 output, and when I retried with mono, now I have 1 output.
Something weird happen. Anyway that’s sorted. Thank you.