Building 3.0 but there's no SConstruct file


Just got the source code from the svn repository. Tried to scons the thing but I get this error:

scons: *** No SConstruct file found.

I did the same thing a few weeks ago and got the same error. When that happened I tried getting the 2.x version instead and that successfully built. I have not previously used scons before so I may be missing something but this appears to be fundamental.

Eric Kampman

./waf configure
./waf build
./waf install (as root)

Last time I built 3.0 I also had to compile JACK 2 don’t know if still needed

Please don’t use waf install at this time. Just run the result from the gtk2_ardour directory, using ./ardev … Installing is still not fully tested (in fact, it hasn’t even been tested much at all). Of course, if you want to do the testing for us (which means filing meaningful, useful reports on any errors) then please go right ahead.

It’s not ‘needed’, it’s the build system that is used and comes within the Ardour source tree. type ’ ./waf '.

@deva : Ditto. I never realized that the installation procedure might need debugging. :wink: It’s worked fine for me since my earliest builds of A3 (many builds ago).



I saw the response to a similar thread that waf is needed.

Will see what that’s all about.

./waf configure --prefix=/some/path
./waf build
./waf install

By the way Paul, I have been using “./waf install” for quite a while and it seem to work as it is.

Oh ok, then that’s a good way to test the general build without having to install to system.

Thanks for the tip!