Building 2.7.1 with LV2 support

I’ve not tried building Ardour for a while, but since my distro now has LV2 in the repos I thought I’d give it a try… I’m using Mandriva 2008.1 and I’ve installed the following:

libslv2-devel 0.6.0
libslv2_9 0.6.0
lv2core 2.0
lv2core_devel 2.0
slv2 0.6.0

Then I do

scons LV2=1

and I get

Checking for slv2… no
LV2 support is not enabled (SLV2 not found or older than 0.6.0)

I’ve got version 0.6.0… it’s installed… what is scons looking for and why can’t it find it?

Bug, perhaps…
Have you tried 0.6.2 ?

Also, you might need to upgrade scons; ardour seems picky about which scons version you’re using. 1.1.0 or 0.98.5 and python 2.5.2 appears to be OK here at least.

I think you’re gonna have to download from here

and compile, I had to do same in my ubuntu box.

Download what version?

maybe latest?

0.6.1 is needed,

You’ll probably soon find out as I did that LV2 is more fun to play around with compiling than it actually is to use, not much choice there, and a loooooong way to go.

Hmmm, if I’m not mistaken you actually need 0.6.2 (which is the latest) for ardour 2.7.1.

As for LV2 choices check out the bottom of There’s also the plugins which show off the LV2 GUI possibilities.

So if I need 0.6.2 why does it say

“SLV2 not found or older than 0.6.0” ?