Build of beta (midi) trunk failed...


It’s my second attempt in two days to build the beta trunk and each time, it fails. I just wanna try it to look at the midi side of things…

Here is a copy of the terminal window:

g++ -o libs/ardour/ladspa_plugin.os -c -g -DARCH_X86 -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -Wall -DHAVE_LIBLO -DENABLE_NLS -DVST_SUPPORT -D_REENTRANT -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Woverloaded-virtual -DPACKAGE=“libardour” -DLIBSIGC_DISABLE_DEPRECATED -DDATA_DIR="/usr/local/share" -DMODULE_DIR="/usr/local/lib" -DCONFIG_DIR="/usr/local/etc" -DLOCALEDIR="/usr/local/share/locale" -DHAVE_JACK_CLIENT_OPEN -DHAVE_JACK_RECOMPUTE_LATENCIES -DHAVE_JACK_RECOMPUTE_LATENCY -DHAVE_JACK_VIDEO_SUPPORT -DHAVE_JACK_PORT_ENSURE_MONITOR -DHAVE_WORDEXP -DHAVE_SYS_VFS_H -fPIC -Ilibs/pbd -I/usr/include/glib-2.0 -Ilibs/surfaces/control_protocol -Ilibs -Ilibs/libsndfile -Ilibs/sigc++2 -Ilibs/glibmm2 -I/usr/lib/glib-2.0/include -Ilibs/ardour -Ilibs/fst -Ilibs/midi++2 -I/usr/include/libxml2 -Ilibs/soundtouch -Ilibs/libsndfile/src libs/ardour/
g++ -o libs/gtkmm2/gdk/gdkmm/drawable.os -c -g -DARCH_X86 -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -Wall -DHAVE_LIBLO -DENABLE_NLS -Woverloaded-virtual -Ilibs/gtkmm2/gtk -fPIC -I/usr/include/atk-1.0 -Ilibs/sigc++2 -I/usr/include/glib-2.0 -I/usr/include/gtk-2.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -Ilibs/glibmm2 -I/usr/lib/glib-2.0/include -Ilibs/gtkmm2/pango -Ilibs/gtkmm2/gdk -I/usr/lib/gtk-2.0/include -I/usr/include/libpng12 libs/gtkmm2/gdk/gdkmm/
libs/ardour/ardour/vst_plugin.h:69: error: invalid covariant return type for ‘virtual std::set<unsigned int, std::less, std::allocator > ARDOUR::VSTPlugin::automatable() const’
libs/ardour/ardour/plugin.h:133: error: overriding ‘virtual std::set<ARDOUR::Parameter, std::lessARDOUR::Parameter, std::allocatorARDOUR::Parameter > ARDOUR::Plugin::automatable() const’
libs/ardour/ardour/plugin.h:136: warning: ‘virtual std::string ARDOUR::Plugin::describe_parameter(ARDOUR::Parameter)’ was hidden
libs/ardour/ardour/vst_plugin.h:77: warning: by ‘std::string ARDOUR::VSTPlugin::describe_parameter(uint32_t)’
scons: *** [libs/ardour/processor.os] Error 1
scons: building terminated because of errors.

Any ideas what I’m doing wrong?

Thanks a lot.

Oh BTW, I build with scons VST=1

scons VST=0

none of the people working on trunk use VST=1. its not likely to work again for a while. trunk is not intended for widespread testing yet.

Thanks Paul,

In fact, later last night I compiled only with scons (without VST=1) and all went well…

compilling with vst=1 fails over a frew weeks on the svn trunk. but building with vst=0 was nearly in every revision i tested no problem.