Build 2158

I had problems with a session in Ardour. Loading it up was begging for Jack to crash. So I upgraded with svn update and I ran into some problems with ALSA not being recent enough so I got a copy from (v1.0.14) and built and installed it.

Then I used SCONS to build ardor (seq.h contained #define SND_SEQ_PORT_TYPE_SOFTWARE (1<<17)) and I loaded up the project. Now, I get no output from the master. Actually, I get nothing into the master either…

I’ve checked all the inputs and outputs of the individual tracks and master and they all look correct. I removed Jamin from the picture to no avail. Something is hosed with this version of jack/ardor/alsa and I’m not even sure where to begin looking.

The problem I was trying to fix has plagued us for a quite some time. We haven’t solved out what causes it, but once it happens, recovery seems to be impossible. Somehow the session gets corrupted to the point that opening it consumes tons of CPU and causes it to make what can only be described as a bumping noise. Totally worthless…

Does JACK need to be rebuilt with the new Alsa? I’m trying that now.

2.0-ongoing branch

A little more update on this problem.

During a mix down two tracks got named the same thing. When they got “de-duped”, something went very wrong and they both got the same Region assigned to them. I’m guessing at the moment, this is what was causing the problem. (still not sure, going to try and repro the issue tomorrow once I have had some sleep)

Because of the Alsa update, I can no longer get any sound of of Ardour via Jack. I have jack running, I have ardour connected, I have sound on several of the tracks, but nothing is on the master bus (no signal present in mixer). I created a new Bus (Bus 1) and routed a track to it, and on this bus the level moves (in the mixer), but it still doesn’t come out on alsa and the speakers.

I think the alsa issue may be with alsa, but no signal on the master bus seems to be an ardour error based on the fact I can create a new bus and it works just fine.

Which svn are you using?
I think the trunk has quite a lot of changes and new stuff in it at the moment and so is a bit touchy on occasion.

Were you using 2.0.3 built from source before changing to svn?

No idea about the other problems.