Bugged session hangs my Ardour or even PC

I’ve got a strange problem with one of my sessions.
I’m on Debian 10, i7-4770 and with 16gb of RAM, Ardour 5.12.

So the problem is that this session hangs my system. Or Ardour itself.
I can’t add a new track, I can’t save session or even exit the program because it just hangs.
Sometimes it hangs the system, as I wrote before. I’ve tried to make such basic operations in other sessions and, surprise, I can add tracks to them, I can save them and I can even close Ardour. Fantastic.

And yes, I know, safe mode with plugins turned off - I’ve tried it. No luck here too - this session keeps hanging even in safe mode. I’ve also tried to disconnect all inputs and outputs (I had problems with Ardour before, such as sound not working at all and got them solved by “reconnecting” the virtual audio I/O) and still no luck. Finally, I’ve tried to disable monitoring (see problem above, I’ve solved it that way too), but that ain’t helped too.

So, what should I do? I need that session and I don’t want to throw it away because of some sort of bug.

i gues, that you already tried that too, nevertheless, is there a session backup file in your session folder (somthing like “[sessionname].ardour.bak”)? if so, you could rename it to “[sessionname].ardour” and see, if this file works.

Actually, no, I haven’t tried it.
But I’ll give it a shot, thanks :wink:

Well, unfortunately, nothing helps.
There was a problem with position marker and start/end positions - I’ve somehow managed to move end marker far away and couldn’t move it back. I’ve “fixed” it by manually editing the session file and also removing position history from the session history file.

I also thought that this session behavior may be because of 4k Display I’m working on, but as I wrote earlier, other sessions have no such problems.
Only this particular session is bugged in some way and hangs. I can’t even render the file.

What should I do?

UPD: Okay, I think I’ve figured this out. The problem is that I’ve moved the playhead far away too. It’s basically out of session range. So when I’m trying to move it back, the interface hangs.
How can I move it back? I’m trying to look it up in the session file but can’t find it.

UPD2: Alright, I’ve fixed it. I’ve managed to reset playhead position by manually editing “instant.xml” file in the session’s folder and setting playhead’s position to 0. It was set to “9223372036854775806”. Nice, huh?
I think we can count that as a bug, actually.

1 Like