Broken Sample Rate

Hi - just to provide some info, I’m running EndeavourOS, which means I’m using Pipewire. If anyone wants more info on the setup I can try to provide it, but honestly getting it set up at all stumps me. Essentially, the issue is as follows: I was creating projects in Ardour using a Scarlett 2i2 set to 48khz, as of yesterday. A system update today seems to have broken that. As of now, I can only create projects at 44.1khz, and I can’t edit my older projects without misaligned sample rates leading to extremely crunchy unusable audio.

I’ve edited the pipewire config in my home config folder (and the one in etc, in case) to set my default sample rate to 48000, and to allow 48000 and above (removing 44.1k from the allowed line).

At this point I’m really unsure what to do. I don’t know where the root of the issue is, but it’s only Ardour which is having actual problems (everything else is just working as normal).

I really appreciate any help. Ideally I’d like to start recording at higher sample rates, but I can’t even set that at the moment, only 44.1k.

I had exactly the same problem as you (Sep 8, RME Babyface Pro): Yesterday projects running at 48kHz, today defaulting to 44.1 kHz and no apparent way to change it, either in Ardour or in configuration files. I successfully reset the defaults in Audacity (Edit >> Preferences >> Quality). These changes stuck and carried over to Ardour. Go figure…!