Big6 routing works in Ubuntu Studio but not AV Linux

Hi, apologies in advance as I don’t believe this is a problem with Ardour but I have a very strange issue with routing my SSL Big6 into Ardour.

I’m dual booting Ubuntu Studio 22.10 and AV Linux 21.2.1. I’ve got an SSL Big6 USB interface running into Ardour 7.4 on both systems. I’m trying to sum a mix, the SSL Big6 allows a return from the main output on channels 15+16 so to sum a mix I’ve created create a stereo track in Ardour with inputs as 15+16.

I’m opening the same Ardour project in both Ubuntu Studio and AV Linux, I can play and route all tracks in the usual way on both systems but on the AV Linux system I cannot get audio in from inputs 15+16. On Ubuntu Studio I can see the relevant connections in Carla and on AV Linux in the Jack Graph view I can see the connections are exactly the same: Channels 15+15 from the Big6 are routed to this stereo track. On Ubuntu Studio I can get the audio onto the track from inputs 15+16, in AV Linux I get nothing, the connections are all setup exactly the same.

Same hardware, same Ardour project the only difference is Ubuntu Studio and AV Linux, I’m at a loss to understand why I can’t get the audio in from 15+16 in AV Linux. Other inputs in AV Linux are working fine, I’ve tracked most of this project in AV Linux.

Anyone got any ideas?

Perhaps ALSA Mixer has controls for that interface, and the settings are different between the two distributions.

Good shout Chris, unfortunately Alsamixer is showing exactly the same settings in both distros, no difference between them so it doesn’t appear to be that.

@Bransby New-ish hardware support in Linux could be down to the kernel versions being used. Can you report the kernel being used on your two Linux boot partitions?

Hi Tseaver

Yes, AV Linux is running 6.0.0-10.1-liquorix-amd64
Ubuntu Studio is running 5.19.0-1024-lowlatency

Someone in the linuxmusicians forum has suggested it may be a kernel issue too and has suggested upgrading AV Linux to 21.3 so I’m downloading that at the moment.



Just spotted it was you in the linuxmusicians forum! Thanks again!

OK, I’ve updated to 21.3 Wildflower but it looks like the same kernel version and the issue persists. Given it works on the older kernel in Ubuntu Studio do you think it’s worth rolling back the kernel version in AV Linux to match Ubuntu? I’m guessing not because it’s a specially customised kernel on AV Linux and I’m guessing I’d create more problems than I’d solve trying to roll it back?

Sorry have been on vacation and not checking the forum(s) for a few days…

The Kernels available for AVL-MXE 21.2.1 and 21.3 will be the same because they are all based on MX-21 ‘Wildflower’. Kernels are just Packages installed by the Package Management system so you can install both older and newer Kernels than the stock one, if they don’t do what you need then you can simply uninstall them afterward as long as you have at least one Kernel installed on the system. For a list of liquorix options available to install use the “MX Package Installer” and on the ‘Enabled Repos’ tab type in ‘liquorix’ to search for other installable liquorix Kernels…

1 Like

Thanks Glen this is really useful. Have you come across any issues like this with this kernel or do you think I should log a bug report or something somewhere? Assuming I try a different kernel and it solves the issue I mean

Have you tried with a fresh project to see if it works at all on AVLinux? I assume the project in question was created on the Ubuntu system.

Hi, yes I tried creating a brand new project in AV Linux created two new stereo tracks, imported an audio file onto one then tried summing it back through the desk and onto the other track via channels 15 and 16, again it didn’t work.

I’ve now tried two other kernels 5.19 and 6.4 and the problem persists on both.

It feels like a Jack issue but I can’t see any difference in the setups between the two.

The only setting I can see that feels like it might impact what I’m trying to do is “Self connect mode”, but on both systems it’s set to “Don’t restrict self connect requests (default)”.

Not sure how to debug the jack. Are you using qjackctl? You could probably diff the config files for that on the two different systems:


So I’m using qjackctl on AV Linux, but Ubuntu Studio has a Studio Controls interface that controls a lot of the settings in qjackctl. However I can still see those settings in qjackctl in Ubuntu studio and I can look at the config file.

Looking at the 2 side by side they appear to be mostly identical or very similar, the main differences are under the [GraphNodePos] section, I’m afraid I’m not really sure what this is referring to, it seems to be referencing other modules and bridges on the systems but here they are in case they’re relevant:

Ubuntu Studio:
14%3AMidi%20Through%3AInput=@Variant(\0\0\0\x1a@f\xc0\0\0\0\0\0\xc0m\0\0\0\0\0) 14%3AMidi%20Through%3AOutput=@Variant(\0\0\0\x1a\xc0w\xe0\0\0\0\0\0\xc0\x66\xc0\0\0\0\0\0) PCH%2C0%2C0-in%3AOutput=@Variant(\0\0\0\x1a\xc0w\xd0\0\0\0\0\0\xc0N\0\0\0\0\0\0) PCH%2C0%2C0-out%3AInput=@Variant(\0\0\0\x1a@y\x10\0\0\0\0\0\xc0W\x80\0\0\0\0\0) USB1%2C0%2C0-in%3AOutput=@Variant(\0\0\0\x1a\xc0r@\0\0\0\0\0\xc0\x61\x80\0\0\0\0\0) USB1%2C0%2C0-out%3AInput=@Variant(\0\0\0\x1a@p\0\0\0\0\0\0\xc0\x62\0\0\0\0\0\0) a2j%3AInput=@Variant(\0\0\0\x1a@L\0\0\0\0\0\0\xc0W\0\0\0\0\0\0) a2j%3AOutput=@Variant(\0\0\0\x1a\xc0\x65@\0\0\0\0\0@\xc0\0\0\0\0\0)
ardour=@Variant(\0\0\0\x1a\xc0` \0\0\0\0\0\xc0S\xc0\0\0\0\0\0)

AV Linux:
Guitarix=@Variant(\0\0\0\x1a\xc0 \0\0\0\0\0\0@k\0\0\0\0\0\0)
system%3AInput=@Variant(\0\0\0\x1a@\x8b#UUUUV@\xa7\xdc\x11\xf7\x4~) system%3AOutput=@Variant(\0\0\0\x1a\xc0\x8f\xb3\xb5\xf9\xd4\xd1\xbc@m\x97!\xed~x)

As an update, on the advice of Glen above, I’ve tried using ALSA directly in Ardour, rather than Jack (something I’ve never tried before for some reason).

Ardour still happily sees all connections and I’m able to make all required connections but the same problem persists, on Ubuntu Studio the signal comes in, on AV Linux, despite being able to make the connections, no signal comes in.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.