Better startup experience for less common display sizes

I use a laptop with a 900p display and a desktop with a 1920x1200 monitor and they always start up at 1080p display size. There needs to be an option for Ardour to start up maximized and to have the window size set to whatever it was sized to last. I hate wasting time resizing windows every time I start up Ardour.

Ardour does remember and restore the most recent window size and position. It is saved in the file instant.xml with each session and globally for new sessions in the config folder.

There’s a line e.g. <Main x="96" y="1200" w="1698" h="815" current-tab="mixer"/>

What OS do you use? And if it’s Linux, what desktop-environment and window-manager?

I was using it with Windows

@x42

Robin,

Speaking of startup… In 6.8 this behavior has returned and I need to click on it to get it off the top of the audio/midi setting window.

This is a bit off-topic here, but current git (Ardour 6.8-63-ga069af796d) now has a Preference > Appearance > Quirks > Show/Hide splash screen instead of setting z-axis stack order option for window-managers that don’t properly support z-axis layering.

There’s probably a hidden KDE setting as well, to make it confirm to freedesktop.org specs in case you’re stuck with 6.8.0

1 Like

As for the original issue. Could it be that Ardour doesn’t fit on 900px height by default?

If the window is larger than the default desktop size, “maximize” does not work properly.
You can try two things:

  • Scale the GUI down (Preferences > Appearance > GUI/Font scaling)
  • Menu > Window > Preferences > Detach – In some cases it’s the preference pane that requires a significant amount of vertical space. detaching it into its own window may allows the main GUI to retain its size (and position).