behringer x1204 records but doesnt playback

hi there. i’ve been searching and had no answer to the fact that the behringer x1204 wourking through ardour records but doesnt play the recorded track…so hope this can be solved here…

theres is a new behringer x1204 runing on ubuntu studio ¿, with ardour and alsa driver.

the matter is that i can record through the mixer but when i want to play that recorded track over ardour it just doesnt sounds…there is a waveform and recognition in the chanel, but it doesnt sounds…just when i do export to wav or flac i can hear the record

so, thanks and hope someone could help

this isnt an ardour specific problem. its more likely a driver issue or that ardour is not routed to the correct outputs.

Its possible that playback 1 and 2 are not the outputs that are connected to your speakers. Use the patchbay to try different outputs.

ok…but the only outputs patchage or jack shows are those called system playback 1 and 2…and those arent working nor for laptop speaker or the mixer’s outs

look. this is the actual setup

i suggest checking that you’ve told JACK to use the correct device and that it has successfully done so.

“To make computer playback go through to the Control Room knob (and then out through the Control Room outputs) you need to depress the “2TR/USB” button to the left of the “PHONES/CTRL RM” knob. To make the mixing desk microphone/line inputs go to the Control Room level knob you need to depress the “MAIN MIX” button.”

this might be your answer

ive just looked at your photos, the outputs from your tracks are not connected anywhere. they need tobe connected to the master in. Looking at your patching audio out on your tracks are not connected anywhere

veda_sticks - good catch! why didn’t i notice that? dparago: you should have left the default options in place for track input + output connections. It appears that you either disabled automatic connections or you manually disconnected them.

for the first, yes, the recording signal comes from the behringer device because when i do export as mp3 or flac i can listen to what y played…so this is right…

and about the connections all i can understand is that the ardour outputs are connected to system playback 1 and 2 and it doesnt sounds through the pc nor the mixer…and there are no more “playback” devices…

for that about duplex mode and automatic connections i have no idea about that…i mean, i havent modified this parameter as i dont know where they are…leatus penguin

the routing through the buttons are ok…i have tested them with some windows soft and they are fine as you said, veda-sticks

your audio out 2 and audio out 3 arnt going anywhere.

Im not sure why you were able to export and the exported file was fine though, as it should take it from the master out. You should have had a silent audio file

route the output of your recorded tracks to the master bus and you should here audio.

Hi dparago, i would like to know how long you use your behringer pult, and do you have a manual?
What software plays your exported tracks, and is it jack software or “just” audio player working
direct with alsa? Do you use phonon

… two buttons in master section. Both are red colored, and left one is recording mode “activator”
other one ( on the right side ) is a listening “activator”. So, “somehow” this pult ( i must use 4 of them :slight_smile: isn´t user friendly machine. :slight_smile:
Surface of this product is “super confusing shock”!

As i can see, your jack routing is confusing me.
If you record tracks, you set them to master as out when you listen them ( masters of ardour)
and masters are connected to system playback.

Why you use monitor/audio 1 and 2 ?

dparago: the ardour outputs are connected to system playback 1 and 2 … the only outputs connected to system:playback 1 and 2 are the monitor outputs and the auditioner outputs. Your actual track outputs are not connected to anything. Ardour does not do this by default.

ok, leatus penguin, the autoconnection within ardour is enabled…and, doesnt happens anything. but, when i manually go to the bottom button for the chanel strip and enable the arodur buses with audio 2 out i start recieving signal within the master as shown n the first pic:

but still not doing any noise through none of the behringer outputs…

and this is how it is actual state of the conexions

sorry brother, can you be more speciffic…i mean, which one should i plug onto what…

thanks again!

ok, i pluggerd mastr audio out 1 and 2 into system playback 1 and 2…but still making not aniy sound…

Of course is isn’t making any sound.

I said above: Your actual track outputs are not connected to anything

You either manually disconnected them, or you chose the option to manually connect them, and then failed to do so. Both are mistakes in almost every case.

I suggest (strongly) that you start a new session, make sure that automatic connection is enabled by default (“Advanced Options”) in the new session dialog.

you need to connect your tracks to ardours master inpiut, just like you would assign on a real desk the channels to “master” or "mix channels in ardour need to be assigned somewhere if its not done by default. in the mixer screen at the bottom of your track theres a box, right click it and youw ill get a list of connections. select master