Behringer X-Touch

Hi guys. I just did a complete overhaul to my project studio which included a rethink on the recently learned capability of the X-Touch to control both the X-Edit software and the DAW. Prior to this recent rewire I had the X-Touch in Midi mode using one of the ports on my MIDI patch bay. Now I have the X-Touch wired into the PC via USB with an Ethernet going to a router for control (which also connects the XR-18). I don’t think I need both USB and Ethernet but I’m digging into how these interfaces work. When I go into Ardour’s Control Surface config. window and use the drop down for it’s communications in/out I don’t see USB. I do see all of my midi ports avaible but I also see an item called “X-Touch”. None of these options seem to work. Can Ardour use USB for X-Touch control or midi only?

Thanks guys,

With the x-touch, Ardour works with this a a midi device. If you connect the USB B connector on the back of the X-touch to your computer you should see a new midi port appear. This is the MIDI port to use. Set the X-touch to use the “MC” protocol (not HUI… which doesn’t work). From the control surfaces select mackie control and you should find a profile for the X-touch. The X-touch midi should be connectable from within the control surface dialog.

Hey Chris,

I use a X-Touch Compact plugged via USB.
It exposes a Midi port via this class compliant USB interface so it’s normal for it to show up in the list as X-Touch.

However, I don’t think there’s a default MIDI map when using the X-Touch in MIDI mode… You’d have to configure that yourself or use the MIDI learn function.
I use mine in Mackie mode for which there is a readily available map that works out of the box. (there’s one for the X-Touch too)

Hi Vincent,
Thanks for the reply.
Hmm I can’t get it to work in USB mode at all. I set the X-Touch to “MC” and USB then in Ardour I set the “Surface sends” and Surface receives" set to “X-Touch”. Nothing. I also tried other options in this drop down list but I think the “X-Touch” is I guess internal MIDI via USB.??

My plan after seeing what’s possible with the X-Touch is to have it control both the DAW (Ardour) and the X-Edit software for the Behringer XR-18 but from what I can tell it’s only possible in network mode. I really would like to stick to Ardour so I would really like to understand is this is possible.
Where are you seeing the mapping configurations? I’m only now beginning to dive into this after owning the XR-18 and X-Touch since July. I’m feeling a bit overwhelmed.

oh sorry Len I didn’t see this message until after I read and replied to Vincent.
I did exactly what you’re indicating but no go. There is actually two “port” options that show up in Ardour that I didn’t seen prior to this last go at hooking everything up. I see “X-Touch” and “MIDIOUT2 (X-Touch)” I don’t know what the “X-Touch” option is refering to or how it got there but the “MIDIOUT2” seems logical that this would be the right choice. So I now set up the X-Touch for “MC” and do I choose Midi or USB for the IFC on the X-Touch? Neither worked but I’ll give it another go.

Maybe try watching Mixing with a Behringer X-Touch in Mixbus (v3,4,5) - YouTube
I think it explains it better than I did. (for Mixbus but the menus should be the same)

Hello guys. Len I appreciate the effort but that video doesn’t contain anything related to this topic. Maybe the wrong video link? Thanks anyway buddy. ok I got Ardour to work with the X-Touch using USB. Although this wasn’t the primary goal at least this works. The trick was after setting the X-Touch to MC and USB Ardour had to be restarted. Here is what I did to have it work. I disconnected the USB from the X-Touch, then started Ardour. I wanted to confirm that only my midi ports for my MidiSport 8X8 and XR-18 were showing up. They were that’s all that was there (well beside the MS synth). Then I connected the USB cable to the X-Touch. Restarted Ardour and navigated to the Control Surface dialog. It had automatically chosen the “X-Touch” midi option. When I clicked on the “Discover Mackie Devices” it started working. Even if I disconnect the USB cable from the X-Touch this midi option will remain in Ardour. So it’s cached I guess. It’s vital that after the USB connection is made to the X-Touch that Ardour be restarted.

Thanks again guys for pointing me in the right direction.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.