Behringer UMC22 with Unbuntu studio unable to connect

Yes, another newbie here (retired). Have UMC22 that does work with win10, so the interface is good. But now want to ditch windows, and have installed ubuntu studio to Dell E4310, installs Ok.
In windows I had to download ASIO for the UMC22, but now, Ardour there is ALSA? tried to find out more about ALSA, but everyone is talking about the CLI. I am not at all good with CLI. Did use vanilla ubuntu as a work machine, as it was free and reliable.
Now, if I sudo lsusb, I can see something like;
Bus 002 DEVICE 008: ID 08bb:2902 TEXAS INSTRUMENTS PCB2902 AUDIO CODEC.
So ubuntu knows that the interface is connected.
Now, how do I get Ardour to connect to the interface?
I have many different ways (searching on the net), but I do not know why and what is going on.
Anyone else having similar issues, thanking anyone, in advance, regards, David

You would get Ardour to connect to the device by selecting it in the audio/midi dialog which likely comes up when you first start Ardour and create the session. You can also pull it up by going to Window>Audio/Midi Setup once a session is open.

If you have already tried this it owuld be helpful to post what is or isn’t happening, with a description of any errors/etc. you see.

   Seablade

Thanks for your reply.
I found the Audio/Midi setup.
Changed the input from Intel to USB AUDIOCODEC.
Started. Failed to open audio device.
This audio interface does work with windows, on another PC.
Is there any other method, thanks and regards, david

I have the Berhringer UMC2 (running Linux Mint) and it works on my system. I am using Jack QJackCtl and you can select the interface in the ‘setup’ section.

This means that another audio service is using the audio device. I recommend either JACK or Pipewire to act as an intermediary layer that makes it so multiple applications can access audio devices.

Unfortunately this is exactly the kind of thing that turns away many potential converts to Linux before they even start. The OP is not even familiar with ALSA yet, so adding JACK or Pipewire into the mix is likely to do more to confuse the issue (I haven’t figured out pipewire yet and I develop audio software for a living…)

The simple way to do audio on Linux (if you are moving from e.g Windows) is:

  1. Install a stock standard Ubuntu e.g. 20.04LTS. It will work just fine, comparable at least to Windows. And often less things will be broken than using a tuned-up ‘Studio’ version. it might not be the most highly optimized or tweaked for the highest performance, but like a reliable car it will get you where you want to go.

  2. For ASIO, think ALSA - its not specifically the same but it fulfills the same role. Its the driver for your soundcard, and most class-compliant USB devices are supported out-of-the-box, so unlike Windows you might not even need any specific drivers.

  3. Use your DAW of choice and select ALSA as your I/O just as you would ASIO in e.g. Windows.

Just like on Windows / ASIO you may find that there are issues if multiple applications try to use the audio at the same time, but there are workarounds.

Example: I just installed Ubuntu 20.04LTS, plugged in a USB interface, downloaded Reaper for Linux (but of course you could use Ardour), started the application, selected my ALSA interface in the audio prefs just like ASIO on Windows, and it works just the same. I wouldn’t necessarily know it was Linux.

The benefit of Linux, is that you can customise and tweak the configuration, but now, fortunately, you don’t necessarily have to.

Unfortunately this is exactly the kind of thing that turns away many potential converts to Linux before they even start. The OP is not even familiar with ALSA yet, so adding JACK or Pipewire into the mix is likely to do more to confuse the issue (I haven’t figured out pipewire yet and I develop audio software for a living…)

Alright, this is a fair criticism, but we also don’t know the OP’s technical skill level. Maybe getting into the nerdy weeds is exactly their thing?

As far as the rest of the advice, absolutely spot on. I only want to make one addition on the distro choice, and that is if you’re used to Windows, you might find stock Ubuntu to be quite the shock as it looks and behaves more like macOS than Windows (but isn’t really either one). I’d look at Kubuntu or Linux Mint as stable alternatives to stock Ubuntu - both of those are going to be pretty stable compared to Ubuntu Studio (although in defense of Ubuntu Studio, I’ve heard pretty good things overall as of late).

Try that, and if you’re still having difficulties, I’d recommend downloading either the Ubuntu Studio tools (should be available from the Ubuntu repos), or adding the kxstudio repos (how to inside the link), and downloading Cadence+other JACK tools that falkTX has bundled with it. Pipewire is one step above that in complexity, so might not be a good choice for a beginner unless you’re running Fedora34 already - which has Pipewire built in. If that’s the case, this very well could be your issue.

Keep us in the loop @belongumdave and let us know if that helps.

Thank you. Your comments are very relevant to me (maybe others,also) that the move Linux is not as smooth as Windows has trained us to be. Yes I know windows is called bloat ware, but they do have everything inside for the programs and/or hardware to find.
Yes I do like the clean look of Linux, and it does run very well on my old hardware.
Firstly, installing Linux is mostly effortless, nothing to do, really. Now when the discussion get to talking about adding an audio interface, the wheels just fell off my cart.
With windows, I did not have to know too much about ASIO, it is directed at the Behringer support site.
With ALSA, there is a lot more I would need to know about Ardour desktop, as it is very minimal at the start.
I think I will have to take a tour of the online manual, before I can really make any more comments.
I was looking for a quick start, but, looks like I am in for a bit of a read.
I will choose a different distro, maybe the latest unbuntu (not studio), and have a go.
We are in lock down this week, in Melbourne, so I am not going anywhere, so this adventure is also my covid escape, regards, David

Again thank you for your response. I will have a go at unbuntu ( I do find that the clean look is very good, and the usability, just fine, and it does run many of my engineering function quite well, that was some time ago, though). If this is troublesome, I will have a look at Linux Mint, and then Kubuntu.
Yes unbuntu studio tools is part of ubuntu studio, and I think I can understand what goes on, but, do I have to know about ALSA in any detail, and JACK (what is that and how is part of the interface. I do not know anything about it)
Again thanks for the response, regards, David

I would think the UMC22 would just work. You probably don’t need any drivers. The thing with Linux is that a lot of hardware is supported out-of-the-box (as in, ready to go), the drivers are already part of the installation, you just plug-in the hardware and it works. Contrast that with Windows where in a lot of cases you still need to track down third-party drivers, So, ALSA is just the driver. There are ALSA drivers for different audio interfaces, just like there are ASIO drivers for different audio interfaces, but, if the audio interface is class-compliant e.g. designed to work as a standard USB sound card, then the ALSA drivers will already be part of the system. You can just plug in the audio interface and it works. I have a similar Behringer interface here, working with Ubuntu 20.04. I didn’t need to do anything.
Without meaning any offence to the ardour devs, If I didn’t already know Ardour, I would struggle to get it running the first time and I would probably give up. Once its installed and working its fine, but there are definitely hurdles for new users. There are alternatives, I mentioned Reaper, and I don’t want to be talking up another DAW on ardour’s forum, but its easy to install, and it presents just as it would on Windows - very much as a Windows application, so you can just start it, open its preferences dialogue, select your audio interface and everything should work. If that works out then you could approach ardour with some confidence that the audio hardware drivers etc are functional, and all you would have to do is navigate ardour’s first-time setup procedure… :slight_smile:
Useful hint (note to self): If you mess up Ardour’s ALSA / Audio I/F settings the first time you run Ardour, or if you ever need to change them again, you need to go to Ardour’s ‘Window’ menu to find them again, (bizarrely that’s where Ardour’s audio I/F preferences are… gets me every time…)

I think the trick the developers have used in the past is have you open a command line, and paste in these commands, which will download a script from the ardour.org server which lists all the audio devices, and whether another software application is using the device which would prevent Ardour from using the audio interface.

cd /tmp && wget https://community.ardour.org/files/adevices.sh && bash ./adevices.sh

Copy that text, paste into a command line, then copy the output and paste into a reply in the forum here.
You should see at least a couple of entries, since you have the USB device and built in sound.
On my system which has a USB interface and also HDMI audio through the video card I get something like this:
Card 0 (C720M):

  • Playback Device 0 (USB Audio):

    • Subdevice 0 (hw:C720M,0,0):
      used by: pipewire (PID 5084)
      access: MMAP_INTERLEAVED
      format: S16_LE
      subformat: STD
      channels: 2
      rate: 48000 (48000/1)
      period_size: 512
      buffer_size: 262144
  • Recording Device 0 (USB Audio):

    • Subdevice 0 (hw:C720M,0,0):
      closed

Card 1 (HDMI):

  • Playback Device 3 (HDMI 0):
    • Subdevice 0 (hw:HDMI,3,0):
      closed

The “closed” line at the bottom indicates no software is using that device. The “used by” info in the first device indicates it is being used by Pipewire, which is a new software server just coming into use which lets multiple applications share access to an audio interface (replacing an older software that does some of the same, but is a digression you don’t really need to get into right now).