BCF2000 Windows 10

I have a BCF2000 and I am running on a Windows 11 PC. I have connected via the USB-USB cable. I have the 1.07 firmware, and I have installed the drivers.
I have the BCF2000 in LC mode and followed the setup in the manual.
The drivers show up as running and OK in Device Manager. I can see it in the USB popup in the windows taskbar.
I open Ardour and I can see it when I go edit-preferences-control surfaces , Mackie is checked and I go Show Protocol Settings, and in Device Type it says BCF2000. In Surface Send and Surface receive it says disconnected and no options for connection.
What would be the next step to getting this working? What tools are available for testing?

If you want to test the controller itself for function I’d use something like MidiOX. It’s free, and more or less the standard tool for checking/monitoring MIDI. Quite possible that a relatively old device like the BCF/BCRs and it’s drivers might not work as expected with actual Windows or that the device isn’t working properly anymore. Haven’t seen a working BCF2000 for a long time - and they were quite common ten or fifteen years ago.

As I recall, that device stopped working after some windows update a few years ago.

Probably Vista. The switch to 64 bit drivers killed a lot of legacy (and shitty not so legacy) peripherals.

Thanks. I tried Midi-ox and it is a nice program. Unfortunately it sees the BCF2000 but when it tries to communicate it says something along the lines of insufficient memory… Apparently it does that when the midi device is being used by something else, which I checked and it isn’t. I have had this unit working in another setup, so I will have to try and remember what setup it was and see if I can get to going there, on another program to check the BCF2000 is still functioning OK. I don’t want to give up on it, as even though it is old (like me) it is just what I want for what I am doing with this setup.

If you can’t get the USB interface working, you should be able to use the MIDI I/O with another USB MIDI interface.

I tested BCF2000 Mixbus 32C in AvLinux. It works perfectly without any driver installation. If you want to check if your device works at all, try starting e.g. AvLinux from a usb stick and test. I think you don’t get drivers for that anymore for the latest windows. In Windows 10 it no longer worked for me.

I have to check if my trusty-ish bcr2000 still works with W11. These are supposed to be normal midi over usb devices, i can’t think of a reason why Microsoft would drop the support. The BCR still works fine on Linux to this day…
BTW the latest firmware for the BCF on Behringer’s site is 1.10, yours is 1.07.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.