BCF 2000 Mackie Mode broken on Ardour 2.3 upgrade


So, upon upgrading Ardour to version 2.3, my BCF2000 no longer connects in Mackie mode. I’m seeing posts by others with similar issues, but I haven’t found any useful information as of yet…my error message is:

[ERROR]: Error instantiating MackieControlProtocol: The Mackie MCU driver will not use a port with device=ardour
[ERROR]: control protocol name “Mackie” could not be initialized

I’m considering just configuring the BCF to run in a general MIDI mode, but I like the scrub wheel function, and aren’t sure how to implement that feature via general midi.

Any suggestions? Thanks!

i have the same error here. im using version 2.4.1

I believe the problem is likely that the config files were overwritten via your upgrade installs.

This one in particular:

[ERROR]: Error instantiating MackieControlProtocol: The Mackie MCU driver will not use a port with device=ardour

Leads me to think that you’re missing the port designation in your .rc file(s).

Read: http://www.ardour.org/files/manual/sn-mackie.html

Right near the top, the stuff about editing your various .rc files should (hopefully) get you going.

BTW – I’ve built and installed every released version since the MCU emulation was added, and IIRC, I have to do this each time. MY BCF works fine in 2.4…

Well, you were right…that was the issue. Problem solved. I shoulda figured…

While anyone’s here, is there a way to add some functionality to the mackie emulation’s mapping? Are we limited to controlling 7 channels/etc.? Is it possible to map additional pages…control plugin parameters…have another page running JAMin, and so on? Is it an either-or situation? That would be a shame, as I like the jog wheel functions…but would certainly enjoy mapping more controls.

New issue: my system doesn’t see the BCF now.

Ways I could have caused the issue: I aborted an attempt to upgrade Ubuntu to 8.04, and I’ve rebooted my machine a few times.

I’ve run cat /proc/asound/cards several times, after a couple of reboots, and the BCF2000 simply doesn’t show up.

This is probably an Ubuntu issue, so excuse my post here. However, I cannot find any posts there related to the BCF2000 at all, so…

Ok, so on further examination, it looks like something has happened recently…namely, that when I alter the line in ardour.rc to use the BCF in Ardour, upon starting up, it eliminates the line I have saved (yes, I’m altering it as sudo). The line stays in etc/ardour/ardour_system.rc.

What am I doing wrong? Is this the result of an attempt by the code to keep things stable? A permissions issue? I’m not superconfident when it comes to editing config files, but I managed to do all this before with no issues whatsoever (that weren’t user-related, anyway)…

Hi Rayj. I’m assuming you are following the instructions in the manual to the letter and see your BCF in cat /proc/asound/cards. I and others have had the same issue as you and reported here. There is even an entry by Paul in the home page (page number three) with further instructions and comments.
Anyway, consider the following: (Note that I’m far from being an expert. When I say “you do this” take it as “I’m doing this way as a rule of thumb and it works for me”)

  1. Possibly, ardour.rc has already a line beginning with “MIDI-port tag=mcu…”. You have to edit that line to change the device and the type, rather than add a new line.
  2. Edit your ardour.rc before starting ardour, and even before starting jack.
  3. You don’t need to change any files in /etc/ardour. Only ardour.rc at /home/you/.ardour2. And you don’t need to change it as su.
  4. Even so, if you start a midi sequencer before ardour (or at least, if you start Rosegarden before ardour) the line will disappear and the BCF2000 won’t work. So start ardour and then the midi sequencer.

I hope this helps

Thanks Pablo!

I was following your aforementioned points 2 through 4, but I didn’t realize that the existing ‘mcu’ line circumvented the new port line. Problem solved!