Babyface ADAT Outputs not working

Hey fellow Ardourists

I’m currently trying to switch from Win7 to Linux for all my Audio work. For that, I recently sold my trusty RME Fireface UC in favour of a used Babyface (not Pro) with Behringer ADA8200 via Adat for all my outboard effects (which I mostly use as inserts).
I got the Babyface, checked for the latest Firmware (v 225), which supports Linux in CC mode, and hooked it up to my monitors and mixer. The Babyface and ADA are hooked via two TOSLINK cables, both checked and working, and - as RME defines - the ADA is set to 44.1kHz clock master, because in CC mode, the Bf automatically syncs to incoming ADAT signals. The Babyface also shows the signal sync LED, so from the hardware site, everything should work fine.The built-in IO are working just as they should, but after re-cabling all my rack, I tried to run some tracks through the outboard, and couldn’t get it going. There was simply no output. I tested the ADAT cable (switched the in and out cables and also tried another one), but the issue stayed the same: I get inputs, by microphones or line signals, but the converter doesn’t send anything coming from the DAW to my outputs.
Next, I tested the setup in my ol’ Win7 system and, to my surprise, everything worked. Although I can’t run the device in CC mode there (Win7 doesn’t support that), but the settings stayed the same. Here, everything works fine. Every stereo pair gets sent through the hardware box as an insert and the wet sound comes back via the ADAs inputs.
Next, I rebooted back into Linux and tried ALSA as the audio device in Ardour, and also tried it in Reaper, but the issue stayed the same. Outs and Ins are showing as they should, but no routed audio comes through the ADAT ports.

Please help!

My system:
Linux Mint 19.1 Cinnamon
Kernel 4.19.28-041928-generic
Jack 1.9.12
ALSA 1.0.25
Ardour 5.12.0-3
Reaper 5.974

Lenovo ThinkStation S20 (2009)
Intel Xeon W3520 @ 2.67GHz × 4 (HT activated)
12GB PC3-10600E RAM (3 x 4GB)
RME Audio Babyface (the older one, not the new ‘Pro’)
Behringer ADA8200

I really appreciate any help or hint in the right direction!
Thank you in advance!

I just reposted my issue in the RME Forums, and Matthias of RME had a solution right away. I know why I am only buying RME Interfaces. :blush: It’s not only their build quality, but also their customer service is top notch!
https://www.forum.rme-audio.de/viewtopic.php?pid=142300#p142300