Avldrums unable to load in Ardour 6

Hi

I’m having some problems loading the avldrums instruments in Ardour, and in Carla.

In Ardour I just see in the logs (window->logs) that it gets blacklisted, so first of all I’m wondering if there’s any way to see more detailed logs. After that I don’t see any entries for avldrums in the Plugin Manager.

Secondly I’m having more success in Carla, as I can import the Red_Zeppelin_4_LV2.sf2 and the Black_Pearl_4_LV2.sf2 by dragging them into the Rack, and I am able to play it, but the avldrumsUI_gl.so and avldrums.so give the error:

Failed to load file
Could not find the VST main entry in the plugin library

I’ve tried both the 32 bit and 64 bit releases you can download from http://x42-plugins.com/x42/x42-avldrums (http://x42-plugins.com/x42/x42-avldrums)

I’m running a somewhat obscure operating system called Void Linux which may or may not be relevant, but it generally works quite well with most other Linux software.

Any suggestions?

It seems that you’ve installed the plugin as VST, while the plugin is a LV2 plugin.

Ideally just use the installer that comes with the binary from http://x42-plugins.com/x42/x42-avldrums - restart Ardour and it will automatically pick up the plugin(s). Look for “Black Pearl” or “Red Zeppelin” kits.

2 Likes

That’s it, perfect! I’ve moved the avldrums.lv2 folder to ~/.lv2 now and it gets picked up! I also tried putting it in a folder defined in LV2_PATH (export LV2_PATH=$HOME/pluginslv2:$LV2_PATH in .bashrc), but then it didn’t seem to find it.

Thank you so much!