Avalanche of xruns

Guys, I have this issue since yesterday. All of a sudden, I’m having an invasion of xruns, impossible to end.
I opend a track that until that time didn’t have any problem. Every now and then, but rarely, there was an xrun, bur now I have non stop xruns in all the tracks I recorded.
I don’t know what the hell is going on, also because I haven’t changed anything.
Any hint on what might be the reason?

Now that I remember better (if I remember well), the issue has started after I’ve got a message of “wrong alignment” and the feedback icon was blinking or lighted in red (or yellow).
I closed Ardour, then started it again and the feedback icon was off, no wrong alignment message anymore but the xruns started.
Always if I remember well, the only thing I did before the issue was to remove a bus I’ve put after the drums. In the track I had several instruments, aligned from the top to bottom: all the drum kit (hi hat, snare, tom, etc), bass, guitar 1, guitar 2 and so on. I’ve put a bus just after the drum with the INs from the drum kit, and the OUTs to the Master.
Originally there wasn’t any bus, I added it after several modifications to the song.
Then I removed it.
I think from that moment on, I had the issue.
I checked the connections and they seem right: all the parts of the drum kit go to the Master now.
Earlier I tried to open a new project in Ardour to see if I had the xrun issue. There wasn’t any, however there weren’t even tracks added. I just tried to add a .flac that I have on the computer without any issue.
I hope my explanation is clear. I forgot that the xruns issue now it’s in all the works I made, apart the one I modified removing the drum bus.

Your DSP is at 100%, meaning that there is some plugin(s) working really hard.
Try and disable some and see if you can locate the culprit.

2.7ms at 48kHz. – You are using a buffersize of 128 samples/cycle.

Most systems cannot handle that without dedicated tuning. In Ardour’s Menu Window > Audio/MIDI Setup pick a larger buffersize. e.g. 1024.

Menu > Window > Plugin DSP Load will come in handy.

And what should this dedicated tuning be? Anything special besides System configuration from System configuration [Linux-Sound] ? If you are kind…

Thanks for the answers. I’ll give it a try.
The thing I don’t understand it’s nothing has changed compared to the time before I removed the drum bus, all the plugins are the same.

Solved. I increased the buffer size. The thing I don’t understand, though, it’s why all of a sudden I had this issue even if I haven’t modified anything in the tracks.

Have you updated or changed any system software?

No, however I had some error system I haven’t any idea depending of what.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.