AV Linux MX-21 Edition Released!

Hi and Happy Valentine’s Day Ardouristas! :heart:

AV Linux MX-21 Edition has been released and as always an officially supported fully-functional build of Ardour (6.9) is included along with Demos of Harrison Mixbus 32C and Reaper 6.46!

Full scoop on the AV Linux Blog:

Love, Glen

13 Likes

I haven’t had a chance to try it out yet, but I read the manual last night and wanted to give you kudos for the amount of work you put into the distribution and its documentation. I would have burned out long ago.

1 Like

Hi @GuntherT

Nice to hear from you again, you have been a constant source of encouragement and that is the antidote to burnout. Not that I haven’t scraped the bottom a few times along the way…lol

Installed it on my backup laptop, first time the partitioning failed for some reason, at the get go, and had to reboot and try again. Second time was the charm, figured out how to get AlterEgo installed with the YADbridge, set up a little midi region in Ardour to validate, and all worked swimmingly. Very nice work, General MacArthur!

1 Like

Hi Glen,
Thank you so much for still working on AV Linux - it’s my go to install for music making.

I thought I’d share some issues I ran into with the MX-21 release. I haven’t found an appropriate spot elsewhere to describe bugs in AV Linux and the following issues both affect Ardour:

  1. the shift to yabridge for Windows plugin support has a few issues:
  • despite the GUI menu for yabridge, it’s not obvious what one needs to do set it up. The instructions are incomplete - they simply describe that the GUI exists.
  • there are missing links to for the yabridge exe that cause plugin scanning to fail in Ardour. I had to manually link the yabridge…something.exe and .so to /usr/bin/ for Ardour to pull in the Windows plugins.
  1. There are slight naming differences in existing plugins that break migrating projects from the previous version of AV Linux to the MX-21 Edition. For example x42-eq is now named “fil4”. The name change causes Ardour to inject dummy plugins to a project when loaded. LSP Plugins has the same issue with the compressor name I think.

Thanks again for the hard work, it’s much appreciated.

Hi,

Thanks for the comments!

A few things…

Yes Yabridge support and ‘YADbridge’ are brand new for this release and not terribly well documented yet, But in my experience all is working as expected on the Live system and should be installed to work the same way without any special linking required. If you have a look at this Video around the 11 minute mark this topic is covered:

As far as Plugins and name changes etc. that is something that is looked after by the Plugin developers themselves in their respective projects. Other than a small collection of ‘odds and ends’ Plugins in the ‘avl-mxe-extra-plugins-dist’ package I don’t have anything to do with Plugin development or Packaging other than including it in the ISO build.

Thanks for the quick feedback.
The video was helpful - I originally followed the instructions in the PDF manual and those aren’t quite as detailed - didn’t know the video existed.

The issue I had with yabridge was after installing to a host machine and not with the Live USB image. Ardour couldn’t find the yabridge-host.exe for the local user account on the new install. It spits out an error message in the details of the plugin scan.

yabridge-host.exe and yabridge-host.exe.so are installed in ~/.local/share/yabridge, but that directory is not in the default path for a new user. Perhaps that would address the issue. I solved it for me by copying those files into /usr/bin, which works for me since it’s a dedicated music device.

Understood about the plugins.

Thanks again!

Actually thanks, I think I know whats wrong…

I included a pre-loaded Ardour config on the Live system with the Plugins on the system pre-scanned because a lot of people seemed to not understand that yabridge had to be run first before running Ardour in order for WinVST’s to show up… People just seem to think you can just launch Ardour or Reaper and then everything will all just magically be working perfectly without any Plugin scans especially something as extra complicated as Windows VST working on a Linux system… :roll_eyes:

Anyway what is probably happening is when you install AVL-MXE that pre-loaded Ardour config is still set up with paths pointing for the Live ‘demo’ User and not the newly created User you made… My big make it easy plan backfired… :slightly_frowning_face:

I will remove the Ardour and Reaper pre-configs from future releases, Thanks again!!