Auto crossfade in Ardour 5


I’m using Ardour 5 for a while and now that I can configure my keyboard shortcuts I can make it to be almost the perfect DAW. But there is something that I hardly miss while doing sound editing for film: auto crossfades.

I’ve read in this article that it looks to be possible, and even more by default:

A crossfade is automatically created within the overlap

But when I import two audio files on the same track, move the right one a little to overlap the left one (not a full overlap) no crossfade is created :frowning:

Did I missed something ? Maybe is there an option in preferences ? I spent time looking in preferences but I didn’t seen any option that looked like “auto crossfades”. Is this implemented in Ardour 5 ?


1 Like

There is a crossfade. The article that you’re reading, however, is out of date and ought to have been removed.

The default crossfade is “short” - it simply ensures there is no click when transitioning between regions. You can change the default length in Preferences. You can edit the length of any particular crossfade by just dragging the fade handles near the top at each end of the region.

Hi Paul, thanks a lot for your answer. By the way, it’s a great honnor to speak to Paul Davis himself ! The father of the great Jack server ! :astonished:

I’m aware of the micro crossfade to avoid clicks, but for editing audio for video, I’ve a hudge number of regions and I always (I mean, 98% of the time) want crossfades between those regions. Creating crossfades manually for all of those regions overlaps is kind of long and repetitive process.

A video is more clear than 1000 words so here’s the kind of behaviour I really need: (only look to audio track of course).
(Vegas is IMHO a great example of simple, intuitive and powerful UI, for many other little details but this isn’t the subject here)

The bad thing about manually created crossfades is that when I need to move a region that overlap another (with a previously manually created crossfade between the two regions), the crossfade doesn’t dynamically adapts to be exactly the length of the overlap.
Once again, a video is more clear to express this:

Thanks for your time.
(ps: maybe you’re asking why don’t I use Vegas if I seems to be 100% satisfied with it ? Because after years of work in the field of sound I’m now a software developer; and a free software defender since my very young age; and I never used windows since I’m 14. Vegas is / (was ?) the only non-free software I use and the only reason to keep Virtualbox installed on my machine)

1 Like

Ardour has a much more sophisticated layering model than other DAWs. This means that a simple-minded model of what happens when you put one region over another doesn’t work, because the overlap could actually involve any number of regions.

There is more explanation here:

The key idea is that the fades are not a property of the intersection of two regions, but instead belong to every region and crossfade between anything under the region and the region itself. Once you understand why we have to do this, it will become clear why we can’t (generally, at least) connect the length of a fade to the length of the region overlap.

Ardour used to do what you want, but it doesn’t work correctly in many fairly trivial cases.

Hi brunetto and Paul,

Adding to the question above: Is there a specific single command to create a crossfade for the overlap of two regions (on the same track)? I don’t quite find the right command to make a key-binding and also need crossfades a lot in my workflow…

(For example in Cubase you can place two regions with some overlap and just hit “x” (while one of the regions is selected) to create a crossfade for the entire overlap… I need that all the time…)

Thanks a dozen!

1 Like

Sorry for bringing this thread up again; I read through the explanations and understand that Ardour has a great deal of complexity and possibilities here…

But… In a youtube video about the new Mixbus version it is explained and shown that Mixbus had an “auto crossfade” (if you let two regions overlap, crossfade for the length of the overlap) by default, and now in the new version it still has this behaviour as an option (though no longer enabled by default).

So is this Mixbus code? Or is there any way at all to create a crossfade for the entire length of the overlap of two regions automatically also in Ardour? Could this be done by Lua script?

Thanks a lot for clarifying that one last time!

Go to options- colors. Put the “opaque region base” slide further to the left until the regions are transparent, and then you will see the end of the underlying region when two regions overlap.
Cut out the first region as long as you want, overlap the second region and pull the “fade” handle to the end of the region below. This will create the “crossfade” you want.
Ardour has great potential, excellent software that is constantly improving.
This new way of doing the crossfade is very useful in classical music as there is no longer any need to trim exactly the end of the underlying track which is automatically muted when the crossfade handle ends.
Many thanks to all the developers

Hi all
After having kind of abandoned Ardour for 2 years now, in favor of a non-free DAW that I paid for (not much at all), with complex layering as well, but with auto-crossfades between regions when using one layer, I came back here to help a student of mine that is looking for a solution for making simple videos sound for his clients.
First answer: Ardour, of course ! So he started using it and after some hours the fatal question arrived: how to enable auto-crossfades between regions ?? He can’t find the option. And like me he was very surprised not to see something like this somewhere:


Thanks @laex for the tip about Mixbus. Indeed, here in this video (youtube link that points out to the interesting moment) we can see an auto-crossfade between two regions.

So for people that are looking for this and came to this thread, have a look to Mixbus. But … this isn’t free software :frowning:

1 Like

Since Ardour 3 (and MIxbus 3) it is always on and cannot be disabled.

A fade-in of a region automatically fades-out regions underneath and vice-versa.

That video is for Mixbus 2, which is more than 10 years old. This information is not relevant to any recent MIxbus or Ardour version.

Just overlap the regions and then drag the fade-handle (square on each region’s corner) of the upper region to the desired length of the cross-fade. The fade-handles on the bottom corners allow to trim the region while keeping the fade-end position fixed.

1 Like

I used Ardour for a couple of very small hobby projects. I love it, I love that I can use it for free. I have some experience from a short time in my life working in a sound studio (with Sequoia). The one thing that I really miss about Ardour is auto crossfade. I get, that there is an automatic short crossfade for click suppression, but usually I overlap takes to get a soft transition also of background sounds, swap between takes to include a better version etc. Auto-crossface is simply a must-have to me for a DAW. I always thought, that it will come to Ardour one day but now the answer sounds like there is not even the possibility for it.

I know, I am not a paying customer, but if every I go back to media professional production, I will happily pay for Ardour. But, to be honest, missing auto-crossfade would actually be a no-buy argument for me. It makes life so much easier, especially with multi-track classical music recordings. I wouldn’t want to work without it.

I hope this topic will be thought over once more. I promise to make a donation if it gets implemented.

All the best and a happy new year to you all!

Ardour automatically crossfades whenever regions overlap. you can change the duration of the crossfade using the fade-handle (grey square in next to the fade the screenshot below, which shows a track in layered mode)

What Ardour does not (no longer) do is automatically change the duration of the fade depending on the overlap. The common case for fading is to comp different takes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.