Aurdour did not find my files

I am on macOs and Ardour 5.5. and I am new to Ardour.
I am working on a project, which required to add a lot of different files to it.
First observation, it seemed to only accept audio files with the correct sample rate. The warning if it was different made me do the sample rate conversion in another program. Or is there a way to let Ardour do it?
Then when I placed files from outside into the timeline, I thought, maybe it would be better for future ordering to move those files into the interchange folder of the project folder. But by reopening the project it did not find those files, though it claimed it was looking within the interchange and the previous folder. Ok, I closed Ardour without saving and moved the files back to their original place. But on opening Ardour did not find them again, I had to redo my importing again.
Is this a bug or did I not understand something here. This sort of stuff should be a no brainer…

TJ, from my experience you have to convert the files in the correct sample rates before to add them in Ardour. I once tried to open a drum track made with Hydrogen at a certain sample rates, and when in Ardour it worked bad. So all the files must have the same sample rates.
About the files in the project. What I suggest you is once you have imported all the files in a project, save it. In this way you’ll have everything stored in the …/export folder created by Ardour, no matter where the files are.

I did save the project of course, expectedly Ardour did not copy them into the project folder (which is good if you have limited space) but as they had been on a different place on my hard drive the original place is saved. I moved the files then into the project folder into the correct place. I double checked with the message where Ardour tried to look for them. They where there, but Ardour did not accept them. Including the whole folder into the search did not help either and moving them back to its original place again did also not help, the session was lost sort of… Is Ardour maybe incapable of dealing with file names containing spaces??? That would be a bug, would explain that behaviour and should be fixed…

If you manually move files from a place to another, I don’t think Ardour is able to find them. They’re probably connected with other files somewhere else in the computer.
Did you try to create a folder elsewhere? I usually create the project folders on my desktop, so I don’t have to turn around to find them, and also avoid to use accents on the letters. But I do have title with spaces between the letters and there isn’t any problem at all.
Though I don’t know the Mac. I’m on Linux.

Ardour has no issues with filenames with spaces.

There’s a lot to discuss here and it is painfully slow and inefficient to do it on a web forum. IRC is much more appropriate for this, at least if I or another developer is online.

This is a major problem, I moved my files out and back in, they are there, they had been loaded before, but Ardour is rejecting them. A lot of work is lost. It tells me where it looks for them, it does not find them. There must be a way to relink them. Do I have to file a bug report for a major issue?? it seems so… This has never happened to me in any other DAW…

@tjshredder: please see my comment: There’s a lot to discuss here and it is painfully slow and inefficient to do it on a web forum. IRC is much more appropriate for this, at least if I or another developer is online. I work in central european time.

That sounds good, though at the moment I am in New York, might be too late now for you - and I never did IRC.
In the mean time I tried to hack the xml file, reimported the missing files which now have a different id, replaced the file ids. A first test worked, but now I get the message on load, that Ardour can’t read the status…

There are typically knowledgeable people on IRC till at least midnight GMT, and I’m often there during that period too.

@tjshredder: Instead of manually copying your files to the interchange subfolder, either:

  1. tick the Copy to Session option when importing them or
  2. Use the Session > Clean-up > Bring all media into session folder menu.

Ardour can handle the bitrate resampling when importing, with the Conversion Quality dropdown menu in the Import window.