Audition MIDI clips (midi pack) = NO SOUND

Currently using Ardour 5.12 on Lubuntu 16.04 system (air-gapped!), which has been SUPREMELY solid and stable for me. But wanting to add some new tools and skillz to my music production and have recently discovered Ugritone Drum VSTs, which are Linux-native (no WINE or Yabridge incantations, YAY!) and MIDI packs; which will allow me to abandon my EZD3 laptop and work entirely native on Ardour and Linux. Unfortunately, my current system is too old for Ugritone requirements, so it’s time to drag it all forward. While retaining my current system, I’m building a new setup to run in parallel. I want to get it completely “up to snuff” before I pull into production and retire the old one.

My new build is a machine with Debian 12 and KX Repos, which installs Ardour 7.3. Everything seems to be installed correctly & running fine. I even got the Ugritone drum VST installed and working as expected…VERY NICE! Reading the Ardour manual, it appears that Ardour now has the ability to “audition MIDI” clips. Don’t know if this is new to Ardour, but it’s new to ME. Unfortunately, I can’t get any sound from the auditioner. Steps I’ve taken:

  • From the clips tab, I’ve gotten MIDI packs installed, and showing up in the clip selector.
  • I can navigate the MIDI pack directory and choose the clips I want to audition, and automatically play. However, while I see the “play progress bar” moving, there is NO SOUND.
  • At the bottom of clips tab, I can choose the Ugritone VST instrument and the GUI is available to view, but still no sound (from either the chosen clip, nor clicking on the GUI)

Everything I’ve read in the manual indicates this SHOULD work. Found a few (closed) posts on this forum for similar, but not identicaI, issues which also indicate this SHOULD work. Can’t figure out what I’ve missed, or what I’m doing wrong? How can I audition MIDI clips from the clip tab?

Furthering the confusion, I’m able to select clips manually, from the CUE interface, and place clips in the A-P(?) slots, and they play just fine. But this is cumbersome, and time consuming to manually select tracks for the CUE, then manually start them, and manually stop them; simply to audition MIDI clips to find the ones I want to use. There are literally HUNDREDS to go through (thousands, once I install all the MIDI packs I purchased!). I guess the CUE interface could be a workaround for me, but it’s a HUGE PITA, which probably defeats the intended results of a streamlined workflow.

Ideally, I’d like to be able to audition MIDI clips simply by clicking on them in the Clip list, having them “autoplay” to listen, drag the clips I want to the Editor timeline, and repeat until I am satisfied with the drum track created. If I’m reading the manual correctly, this IS possible within Ardour and Ardour 7.3. But it seems I’ve missed SOMETHING. Anyone have any thoughts as to what I’m doing wrong?

EDIT: also tried to audition MIDI clips from the “File>Import” menu. i can select the MIDI files and I see the meters moving, but no sound. The default instrument is ACE Synthesizer, which occasionally sounds a random note, but these are drum MIDI packs…selecting the Ugritone instrument is completely silent. So are the Black Pearl, Red Zeppeling, and DrumGizmo instruments. No sounds from any of them… What am I missing?

In Audio Connection Manager (Window menu or SHIFT-ALT-A), what is the auditioner out connected to?

(Ardour Misc → Hardware)

The default on my system is General MIDI Synth which, nominally, also includes drum sounds. You should also be able to select your Ugritone VST if it’s installed. Note that there’s a couple of bugs that you may encounter if you do this.



Thanks for the reply Keith,

Screenshot attached, so I’m sure we’re referencing the same things:

From the Editor View, clips tab on right, navigate to my saved Midi Packs, which displays a tree view of all clips (perfect…LOVE that!)
At the bottom the default synth is “ACE Reasonable Synth”, which I change to Ugritone Drums. Clicking on a MIDI clip does indeed “auto-play” , with movement on progress bar, but no sound. Doesn’t matter if it’s ACE synth or Ugritone.
To the left of the Editor Track, the selections are “Generic” and “General MIDI”. Not sure how this relates to or differs from Clips tab auditioner, or the Mixer strip, which indicates the instrument is Ugritone Drums.
From the CUE Tab, I’m able to audition clips in the Clips tab by selecting 1 at a time, pressing play (which loops) to listen, and pressing stop to end loop. Move on to next clip…VERY TEDIOUS, but it works.

I looked at my auditioner sources, and none were checked/connected (32 L-R connections, presumably because my Ugritone VST is 32 channels?). I turned all “ON” for the Master Bus input…still no sound. I turned all “ON” for the “system playback” on Hardware tab…still no sound.

I feel like you’re onto something, it’s a setting somewhere…but I can’t find it. Thinking out loud, once fully fleshed out, I’m going to pull my Behringer UMC404HD sound card from old machine and connect to THIS one. But in the meantime, I’m just using onboard hardware sound. Can’t imagine that would be a problem, but I don’t know what I don’t know.

The ability to audition MIDI was a BIG plus, and a huge surprise for me. But auditioning from CUE is a PITA. If I can get the auditioner working from the clips tab, Ardour is just about PERFECT for my use-case scenario. I’m so close! TIA…

My suggestion would be to look at the hardware tab at the bottom, and make sure the auditioner is connected to the appropriate outputs directly, instead of via the master bus.

I would also try General MIDI Synth as the audition instrument first. It may not give the best sounds (although they aren’t bad) but that instrument definitely works with all of the supplied loops.

When you get that working, you can switch to Ugritone and that will, hopefully, also work.



All of this advice is solid Keith, so THANK YOU for that! FWIW, I had done ALL of this, but with no satisfaction. So I undid all my auditioner connections and only connected the auditioner outs to the playback inputs on the Hardware tab, as per your suggestions. STILL no satisfaction, but went to Cadence and restarted the Jack session and shazam…there it was…clip sounds that autostart, using the Drum VST! Don’t know why, but Jack wasn’t picking up the re-wired connections in real time. Jack restart did the trick!

I’m now able to audition MIDI clips right there within Ardour, and place them in the track lane in the Editor…VERY NICE feature! Kudos to the Ardour devs and a big thank you for that feature I didn’t even know I needed, but will come in SO HANDY…THANK YOU!

But now that I have that, I’m hoping for a better way to edit MIDI than doing it in the Editor track lane. The current setup is ideal for pulling MIDI tracks into the project, but not very conducive to editing MIDI tracks that are “close” to what you want, but not quite. Drum hits especially require a certain degree of accuracy to place the notes. It would be nice to have a popup MIDI Editor with grid lines, to help place those drum notes EXACTLY where they need to be (within “human” tolerances). EZDrummer does this VERY well, but is to be expected of a dedicated stand-alone drum software. Reaper has a nice implementation for this, as a DAW. If Ardour had a similar feature, I could complete projects without ever leaving the Ardour DAW! :sunglasses:

Any chance of Devs implementing something similar to the Reaper setup for MIDI editing? Ardour is very close to that…perhaps just a floating popup with “larger” or “magnified” lane with vertical gridlines for timing/placement of notes.

Select the MIDI track, then press “f” … it will fill the entire editor screen. Press shift-z to “visual undo” back to the prior state. Use temporal zoom (- and =) to control the temporal span you’re working on.

You will find our thoughts on a “separate piano roll” for editing if you search the forums for “piano roll”.

Sweet…that works for me! That makes the MIDI lane large enough to work with, and the zoom in/out reveals the vertical lines for lining things up that I want and need to see. You’re already there, Paul! THANKS!

But can I edit individual MIDI notes? Seems like the entire region is selected…if I try to move ONE note, the entire region moves; if I try to delete ONE note, the entire region gets deleted. After I press “f” to get that view, and zoom in, how can I edit individual notes? If I can do that, I think you’ve already implemented what I’ve suggested/requested!

Press “e” to enter internal edit mode (and “g” to return to “grabber” or “object” mode).

Then go read the manual here: The Ardour Manual - MIDI Editing

the “e” is what I was missing…thank you!