Audio Setup: ALSA for recording - PulseAudio for Playback

I just cannot wrap my head around it. Using a Focusrite Scarlett 8 channel audio interface for recording solo piano with four microphones at 24/96. Choosing ALSA as Audio System lets me do this just fine. However, no playback is possible. I can choose the Scarlett as the correct input device and HDA Intel as output device. However, as soon as I start I can see that the Linux audio subsystem tells me “No output device”.

I need to hit Stop, switch to PulseAudio and only then can I listen to something I just recorded.

This is on Fedora 40 with Ardour 8.6.0 on a Thinkpad X1 Carbon gen. 3.

It’s a workable workaround, but I can’t understand why it is as it is. Any ideas?

When using the ALSA backend, the input and output devices should be the same, i.e. select the Scarlett for both and connect speakers to it.

I don’t understand the reasoning behind this. I use the Scarlett as my signal provider for the DAW and my computer is the place where I edit and mix and I do this with good DACs for good headphones.

Audacity allows me to do this, but its mixer interface is terrible, which is why I am looking at Ardour.

The reasoning is quite simple. Ardour is intended as a tool for pro-audio work and music creation workflows. Pulseaudio is not intended to be for such things.

All audio I/O on Linux occurs via ALSA (whether you explicitly choose it or not).

If you are just editing/mixing, feel free to use Ardour’s Pulseaudio backend, which only does playback. If you are recording and monitoring at the same time, you should be using sample-clock synced inputs and outputs, which generally means a single device (i.e. the Scarlett).

If you really insist on using a difference device for recording and playback, you can do that too, but we do not recommend it.

Also, Audacity is an audio file editor. Ardour is a DAW. These are not the same type of application, even though they overlap in some areas of functionality.

Show me how I can record audio on Ardour with the Scarlett and continue working on the recorded material with Ardour using my preferred set of headphones without jumping through hoops and loops.

I read the Focusrite documentation and never was there a hint at how to use the Scarlett in post-production i.e. editing and mixing audio recordings.

I’d say that a dedicated studio with a 200k Steinway concert grand, four microphones set up by a sound engineer who runs a studio for a top orchestra is what requires pro-audio to get decent results.

Right now I can’t see how to do this with Ardour.

And the pro-audio approach is to use the same audio device for capture and playback (or, if you have suitable gear, use sample-locked devices). It’s standard practice in pro-audio circles to drive the control room monitors from the audio interface, and the Scarlett’s have outputs for studio monitors and headphones.

Please be clear on this: this is not an Ardour problem; it’s a “not using the tools properly” problem. It’s a situation that’s common to Linux (ALSA), Windows (ASIO) and Mac (CoreAudio): the default setup is to only allow one audio device to be used at a time when using pro-audio tools.

There are ways around it, but they involve jumping through hoops. If you don’t want to do that then, regardless of operating system or DAW application, your only solution is to use a single device at a time.

Note that there’s nothing stopping you from switching the audio device in the ALSA backend to a different playback device once you’ve finished tracking, and use that for editing.

You could also use the headphone output on the Scarlett, perhaps in combination with a headphone amp if the headphones need it. The Scarlett’s have excellent DACs.



The headphone output on the Scarlett should have better amplification and DAC than an Intel HDA device, especially if you are referring to a laptop’s built-in soundcard. What is holding you back from from plugging your headphones into the Scarlett instead of the Intel HDA?

Plug your headphones into the Scarlett instead of the built in audio? If you need a headphone amp for your headphones, then plug the outputs of the Scarlet into the headphone amp.

I feel like I am missing something there.

… Not sure I understand what you are trying to say here? What exactly is it you are trying to do you feel like you can’t do with the Scarlet Interface?

Nowhere close to this is required to get ‘pro audio’ results. However it has definitely been used in situations like this.


I am sorry I am piggy backing on the thread but I am in a similar situation

  • linux PopOS 22.04 works well without Ardour (using the build in card)
  • When I am using Ardour - I switch to ALSA - I only mix (don’t record directly). Works well but all other sounds are routed to the HDMI cable (not very nice on a monitor - not at all)
  • I don’t have any external audio interface - just the sound card on the computer.

Is there anything that I can do to improve the performance? I am hoping to be able to listen to the regular sounds of the computer while mixing on Ardour.

I did try jack in the past and for some reason I failed miserably. Also - my audio files are recorded on an external device - typically 96 kHz 24 bit. On the grand schema most of the time it is an overkill. If I can make it work without changing the recording format it would be nice but if I must change it to 44 kHz 16 bit - I think I am going to be okay.

Any advice please?
Thank you in advance.

This has been covered dozens of times here.

Ardour deliberately requests exclusive access to the hardware device it is told to use.

If you want to just be able to do playback (no recording) while hearing other software, use the Pulseaudio backend.

If you want to be able to do recording & playback while hearing other software, use JACK or a pseudo-device provided by Pipewire.

Thank you @paul
Switched o pulse and it works well - both sounds are from the speakers at the same time.

Same here. The manual of Scarlett states that both headphone outputs are used for monitoring only i.e. when recording. Plugging in headphones into Scarlett during editing does nothing. Is there a routing option I am missing? Is alsa-scarlett-gui the piece of software for Linux that I need to look at?

My headphones are AKG and I use a separate USB-DAC by Oehlbach in order to avoid the abysmal quality of the notebook headphone output.

Just for background, you might care to read:

That is about USB microphones, but with just a little imagination, you’ll be able to see why the same reasoning applies for USB-connected headphones.

This would only apply if I were trying to use the Scarlett for recording while at the same time do monitoring with a separate DAC that uses a different clock source. That is not the case in what I am trying to do.

I don’t understand why Ardour in a pure playback situation i.e. after I recorded through Scarlett, does not act like any other playback program like mpv, vlc or any other media player.

Ardour can act that way if you choose to use the Pulseaudio backend.

But those tools are for desktop media playback; Ardour is a creation tool and is fundamentally rooted in the idea of using a duplex quality audio interface.

You might just as well ask why mpv,vlc etc. do not use JACK by default.

I might be missing info here, but since you are running Fedora 40 which uses pipewire by default, have you tried to select the JACK backend in Ardour? This should make it work like you expect by the help of the pipewire JACK emulation (which is wired up by the distro unless you changed something here). I.e. you should be able to record and playback in Ardour at the same time while also being able to playback other media in other programs.

Yet, the recommendation of other people here still holds: Just connect your headphones to the Scarlett. I owned a Scarlett 18i8 first gen for a couple of years (sold it last year), and this standard workflow of playback through its headphone port works just fine. While there is no official tool provided by Focusrite, you can do the routing using alsamixer from the command line. Most likely you will want to select “PCM1” and “PCM2” for left and right as the headphone channels during mixing/playback there. Oh, and make sure the headphones are unmuted.

The Scarlett is a powerful device and thus the options are a little bit cumbersome to set up on Linux (blame Focusrite for not releasing a Linux tool!), but it works.

There should be no need to connect yet another USB DAC, the Focusrite’s is sufficient.

Something is missing. What Scarlett are you using precisely? I have yet to see ANY Scarlett you couldn’t use for playback monitoring. This makes me suspect a problem in your setup of the Scarlett Interface itself…

So you are correct there is no official tool, there is a seperate utility for the Scarlett that CAN be a little easier to use than Alsamixer IIRC, which brings me to…

I believe so yes. As mentioned above I believe (Though it has been a LONG time since i used a Scarlett and I rarely used it on Linux) that you can control the Scarlett through alsa-mixer as mentioned above. The utility you are mentioning does make this easier for many people and so long as it supports your interface, which I suspect it does, may make it easier to understand if you are more used to the Scarlett software on other OSes in particular.

Avoiding Abysmal quality built in outputs is of course a good thing, but unless you have particular headphones that need it, the Scarlett output should be a higher quality on it’s own, and as Paul mentioned, it is generally a bad idea to have separate devices for monitoring while recording and recording at the same time. I know you mentioned primarily using it during playback, which I will let other suggestions address using it then, but I suspect you may be able to bypass it entirely if we can get your Scarlett operating properly.

1 Like

I don’t own a Scarlett, but I do think you would benefit from installing “alsa-scarlett-gui” from what I have gathered from discussions on
It may make the routing easier for you to setup. The device is surely capable of playback with the right software connections.

Is that an 18i8 interface? 3rd Gen or earlier?

That is not what the 3rd gen manual says. That manual states “The headphone outputs have independent mixes and carry the signals currently routed to Headphone outputs 1 and 2 (outputs 5 & 6 and 7 & 8 as stereo pairs).”

Try routing the master bus (or monitor bus if you are using the monitor section) to outputs 5 and 6 intead of 1 and 2.

1 Like

I found two things today:

  • By means of alsa-scarlett-gui I can actually use a preset for routing called “Stereo” and this one lets me use the headphone outputs of the Scarlett 18i20 interface. Caveat: Despite its name the output is mono, which makes it completely unusable for me.

  • I managed to use my Oehlbach DAC within Ardour with ALSA backend. It takes one restart in the Audio Setup Window and then Ardour controls this device, meaning that it is not listed in the Systemsettings part of KDE Plasma anymore.

So, I am happy and can now use Ardour the way I initially wanted.

Unfortunately alsa-scarlett-gui is not feature complete compared to Focusrite’s control software for Mac and Windows, but since I only have this one specific use case, I am perfectly fine now without any need to fiddle with the audio interface.