Audio mutes when slaved to MTC

Hi all,

when ardour (2.8.12) is slaved to external MTC and running, audio is muted. When changing the clocksource to “internal” or “jack” it works fine.

Has anyone an idea?


@lambo: it suggests that Ardour cannot lock to the incoming MTC. It will mute audio until it locks. Where is the MTC coming from?

Hi Paul,

the MTC comes from an Tascam DM24 via an AkaiME30P (Midi patchbay). Ardour receives the clock, its cursor is moving in sync with the TC from the gear.

I used an older Version of Ardour (don’t remember which version) as Midi slave succesfully about one and a half year ago, equipment didn’t change. Maybe a problem with the current version of Ardour?


Receiving and responding to MTC are not the same as locking to it. Its been so long since I’ve been near the MTC code in Ardour 2.X that right now I don’t know what to suggest.


thank you for your answer Paul, i know the problem with code one hasn’t worked on for an while. I had a short look into, but my c++ skills are not this good (though the source appeared very readable to me); furthermore i don’t know anything about ardours design/architecture.

The ardour version I used was built from source. So to exclude problems by my own build (although I didn’t change anything via scons), yesterday I took the precompiled binary. It shows the same behaviour, but by starting with a newly created session i found out the following strange behaviour: whenever hooked to MTC (no matter where it comes from, i have different sources), ardour starts capturing on all tracks from time 0, tracks are not armed, record button is not enabled. Enabling/disabling MMC didn’t change anything.
The cursor moves in sync to the tc.

Is there an archive of older ardour releases? I havn’t found one. I would like to try an older version, if possible.