audio input in ardour does not work

i installed jackd and ardour but recently i have not been able to make ardour record sound from the input of my pc on which i have ubuntu. at the same time, audacity can detect and record normally fro the pc input. anybody can tell me what maybe the problem and how to solve it? it’s very important for me to use ardour as a DAWS, but i’m not clever with the terminal and with jack. thanks!!

by the way ardour will run without jack, as it can run with the alsa driver, but i recomend using jack.

if you have jack open and go to connections and see nothing under the readable and writeable clients, jack is not running

with ardour open, create a new track, this should automatically route capture 1 and 2 to the inpyut of the track you just created, then click the arm buttom on the track (red circle) test your input, if nothing happens, look at jack connections to see if capture 1 and 2 have lines going to the right where ardour is. if not manually connect them the audio in.

to do this, click system under readable clients.output, now click capture_1, then on writeable clients/input ports ther should be ardour, click that

now a list of input ports , your track will look like audio in1 or somthing like that, click that and hit the cfonnect button.

dont forget you need to start the jack server and make sure that it is running, you can have gjackctrl open but the server not running. if its not running press start, and on the dispaly next to the buttons it should then say started, if you get errors you need to work out why jack cant start.

if jack is started and running fine, and your capture is routed to your audio inputs, and still nothing. your going to have to check that the system is set to use the right input if your card has multiple, normally this is automatically detected when you plug it in.

you’ll need the alsa mixer, it should be called mixer and is usually under multimedia in your applications menu. with also mixer you can change which input is selected and also the volumes, this may need configured as when i first started it, there were no options.

i’m sorry. i’m tatlly incompetent, but i need to make ardour work!!
this is the situation:
i start jack, and in the jack audio connection kit i find capture 1 and 2 in “out”, and playback 1 and 2 in “in”, with no connections made; in the preferences window, in input i can choos between my HDA intel soundcard and my webcam USB, but in no way am i able to get any sound be detected in ardour recordings!!!
instead, if i run audacity, i can record sound both from the line in and from the usb webcam.
why is that???

another hint: ardour does not seem to receive any audio from any input, BUT it does send audio out, even if there is nothing in the qjackctrl connections window audio in and audio out.

ok, in qjackctrl connections window there is nothing in the audio and out, and there is nothing available to select.
in the qjackctrl preferences window, at the “input” there is the possibility to choose between my HDA intel pc soundcard and my USB webcam. so, what shpuld i do? thanks

i think i already did that check, but i’ll do it again, in connections and in preferences. will let you know, thank you!

When you open JACK’s connections window - does it show the correct connections from the soundcard’s input to Ardour’s track(s) on which you like to record?

If yes - maybe your PC has more than one soundcard so that you may have to select the right one: in JACK’s special window - I guess its English name is “preferences” (I only have a German version of JACK, sorry).


“without jack” is not accurate.

“without qjackctl” is accurate. qjackctl is also called “Jack Control” on some platforms.

thanks veda_stick. i made all steps of the above, so now on my ardour track, capture1 is connected to audio in1 and capture 2 is connected to audio in2, jack is started, the system is set to line in and volume is sufficient, the proof is that with audacity the recording from line in works perfectly fine. but still i can not get any sound to reach my ardour recording track. why could it be so???

stefabarta: what test are you using to establish that no sound is getting into ardour?

open up alsa mixer, i had this problem with line in not working for some unknow reason and i had to open alsa mixer and fiddle with a few things like setting it to line in, and making sure the capture slider was up.

try pluging into the mic input and see if you get a signal, if you do then its probably a setting in alsa mixer, like i had the same problem was getting it fine through the mic input but nothing in the line input until i played with alsa mixer

thanks paul and veda_stick! the problem was actually in the computer settings for receiving the line in. now the recording works fine! do you know if there is a way to save the jack connections from one ardour session to the next? thanks again

well, last recording session everything worked fine. but today i re-opened the ardour file, and even tried creating new ones, and again no sound is being detected while recording!!! checked all jacks connections settings, so the line in goes in the inputs of ardour track, then re-checked the selection of the inputs on the jack preferences, then checked the pc audio in settings, then checked the hardware through which the sound is produced. all steps seem to be verified. in the doubt that the line in of the pc might be suddenly broken, i tried making selections in jack preferences for my usb webcam instead, choosing it even in my pc audio in settings, but nothing comes out!! it makes me crazy, that means there is still a problem along the line that bring the sound to the ardour recording track, but i dont seem to be able to detect where it might be! help!!! thanks

even if i re load a previously working adour session, this time, after i quit ardour and jackd, in the newly open session i was not able to get any sound. so i’m stuck again, without any hint what the problem might be. the only difference i noticed in the settings is that now in the setup window of jackctrl the “interface” is gone to “default” and that it does not let me select anything else since the command seems to be inactive. anyone can help me on this?

now in the setup window of jackctrl the “interface” is gone to “default” and that it does not let me select anything else since the command seems to be inactive

Make sure you select the alsa driver (just above “Interface”)

to pablo: alsa is selected, but still the interface command is inactive. why?

i start getting desperate. sometimes i get ardour to record properly, sometimes no sound reach the recording track of ardour, even in the same session that 1 minute before was working properly! it all seems to be random. i made a lot of cross-checks.
ok,these are all the checks i did:
jack started, jack connections, jack setup inputs, jack setup interface (it’s not active, and is on “default”), hardware line in volume and muting, no other applications running (like skype, audacity).
result: random!!
please help with some ways i could get over this problem that is making any work with ardour impossible! thanks

following and correcting my last post:
i continued to make cross-checking and i discovered that it’s not random behaviour, there is a pattern that is repeatable.
if i start my ubuntu , then start jack, then ardour (with all the checkings of my previous post), the result is i dont get any sound to reach ardour through my line in.
if i then quit ardour and jack, and then start audacity i record perfectly from my line in, then if i quit audacity and start again jack and ardour, ardour records perfectly fro my line in!
if i restart ubuntu and start again jack and ardour without having used audacity, ardour does not record anything!
i’m very surprised, but i’m now sure that it’s working as i describe it.
this should make possible for expert people to detect why the audio does not get recorded in ardour under certain circumstances. thanks for any reply!!!