Aubio not found

Hi Iv’e been trying to build 2.5 on Fedora 9,I have installed Aubio but I get this message. scons: Reading SConscript files …
Checking for pkg-config version >= 0.8.0… yes
Checking for aubio… no
aubio >= 0.3.2 not found.
You do not have the necessary dependencies required to build ardour
Please consult for more information
[pete@localhost ardour-2.5]$

is there an Aubio-dev or somthing I’m missing
Thanks in advance for any help.


Yes you must install the aubio-dev package, I don’t use Fedora but it should be in the repos if the regular aubio package is.

If not you’ll need to compile it from here:

Are you sure you have aubio installed?
In that case there should be a aubio-dev or -devel to install from where you got the aubio rpm (The dev/devel are always needed when compiling something that depends on that package).

Otherwise you’ll have to compile it yourself.

Hi GMaq thats where I downloaded it from and just did ./configure make #make install.Is there somthing else I should have done to compile the devs?cheers Pete

I just worked through this on a Fedora 7/PlanetCCRMA setup. No RPMs available, so I built from source and installed, and Ardour’s scons invocation failed to find aubio.

I believe that’s because I didn’t properly have the LD_ environment variables set, and it wasn’t looking in /usr/local for headers or libraries. I tried uninstalling then re-installing aubio with “./configure --prefix=/usr” but the “make install” failed with the odd message “libtool: install: error: cannot install `’ to a directory not ending in /usr/local/lib”

However, removing the aubio directory, re-extracting from the tar file and building with the --prefix=/usr has done the trick.

Problem solved “./configure –prefix=/usr” got it up and running.
Thanks to all for the help. Pete