AU-plugins again, now tried fresh MacMini and 10.6.X. They do work on stereo tracks but not mono tracks...

Yes. My troubles with my favorite AU-plugins continues.
Tonight I tried intalling Ardour 2.8.3 on my completely new MacMini 10.6.X. The only things installed was Ardour and the plugins. I tried Uniquelizer (former Eqium) and Trackplug 4/5
On stereo tracks they work fine, but on mono tracks (using the same mono audio file) they do not process the Audio, although they look fine.
It seems that they do not go into mono-mode as they did on 10.5.8, (the single panner on the mono now track and output faders in the plugins are/goes stereo).

(If I try these plugins in DSP-quattro, the output faders in the plugins are stereo, even when working on mono-tracks, but they still process as expected. This was not so run on 10.5.8, where the plugin output faders was mono)

Fiddling with these plugins on mono-tracks in Ardour, sooner or later (often sooner) leads to Ardour chrashing, often with an audible tone (for ever spinning sample buffer?).
I also tried one of the Apple plugins called AppleAUMatrix reverb, it crashes Ardour immediately, before the plugin window had time to open.

/On my previous setup (MacMini 1.83 and OS 10.5.8), using Ardour on mono tracks with these plugins wouldn’t work (error message), but they would work on stereo tracks. After having trashed .ardour2 the problem would reverse. Changing back to the old .ardour2 would again reverse the problem back.

Any ideeas?

Of course I could just leave it as is and put all the mono files on stereo tracks, but I suppose it would steal twice the processor power?
Also the twin panner is not so convenient to operate as a single one.

Is there a workaround?

Iäm now back on on OS10.5.8.
Trying the AppleAUMatrix reverb I get this error message (Ardour does not crash until I press the play button):
[ERROR]: AUPlugin: could not set stream format for output/0 (err = -10868)

This plugin works in other applications, such as DSP-quattro.

What is the problem with Ardour vs these AU-plugins?
What is err = -10868?

apple has no documentation for that error. the problem is almost certainly the I/O configuration of the track/bus you are trying to use this in.