Ardur corrupt every session i did in the past

I need some help o restore my Ardour’s sessions.
Some days ago I did some test with Reason and Ardour and I saved a QJackCtl configuration.
Now every session I try to open up that is not related to the Reason test one, won’t open and wil be also corrupted.
I tried to resset the QJacktCtl configuration with the same results.
I tried to launch Jack pilot intead. Same results.
I tried to launch without the Jack engine open. Same results.

What happen basically is:
if I double click to open my session, a windows pops up with the message:

Port Registration Error
Click the Close button to try again

once clicked a second pop up window comes out:

This session … already exist. Do you want to open it? Yes/No

Clicking on yes it opens an empty session with just the master bus.
That’s it.

All my sessions are corrupted like that.

When I try to open the “Reason Session” it opens up, showing, obviously, an error on the bottom:

Audioengine: cannot connect Reason out…

where surely is due to the fact that I have to reload the QJackCtl saved configuration.

Could you please somebody help me? I just lost two week of work and I’m sure my client won’t understand.

After a IRC chat with “las” he found the issue is in the name I gave to the sends, that it was supposed to a resolved bug but not completely.
Here is what he advised to do to sort out the issue:

you need to edit the file that ends in “.ardour”
search for every place where it says:

Send bitslot=“N”

where N is a number
then go 2 lines below each instance of that to the line that starts with

IO name="

change the name in quotes to “sendM” where M=N+1
or actually, any other name of your choice - the only requirement is that they must be unique names