ArdourVST users on Ubuntu Hardy, Is WINE 1.0+ Working? Please Report.


I’m currently using ArdourVST with WINE 0.9.49 under Ubuntu Gutsy 7.10, I’ve found versions of WINE beyond 0.9.51 to not work worth a damn in Gutsy, with issues like doubling of plugin windows etc. I see that the WINE site doesn’t provide the latest versions of Wine (1.0+) for any Ubuntu other than the latest “Hardy”. Now that Hardy has been out for a while and had a revision put out, I’m curious about upgrading but I don’t want to if it’s going to screw up my ArdourVST that runs very well under Gutsy. Unfortunately many other apps under Gutsy are getting dated, and for some ungodly reason packagers like are no longer supporting Gutsy.

I have been compiling some apps to keep current but I can’t and would rather not compile everything. If anyone is running ArdourVST under Hardy, I’d sure be interested in knowing how WINE is behaving itself these days, TIA -GLEN

Hi there, yesterday I downloaded the sources for Ardour on this site and installed wine through Synaptic (I don’t remeber the version but it was yesterday so…:P). The compilation worked great after fulfilling all dependencies and all the VST’s I’ve tested so far now have worked great. All on Hardy Heron.


Thanks very much for replying, I’ve read a lot of negative press regarding Hardy for pro audio, so I appreciate you taking the time to answer my post. It is very frustrating how fast the Ubuntu update cycle is for things like setting up a DAW. I think I’ll set up a test partition before I nuke what I’ve got working here. Thanks again!


In Ubuntu Hardy Heron Wine 1.0+ is still displaying separate Windows for the VST plug-ins themselves and the “wrapper window” with the Preset and Bypass functions. Frustrating!!!

I solved this by uninstalling WINE 1.1.4 and compiling WINE 0.9.50 from source. Now the Windows behave properly in case anyone else wants to correct this behavior.