Ardour's too slow / Plugin's going crazy...

I’m using ardour for a while and had no problems installing it, but I still have big problems configuring it.

I run Jack 0.101.1 via QJackctl 0.2.20 on Debian unstable kernel /w realtime patch.
Ardour is V 0.99.2
Desktop Manager is Enlightenment
my pc: 1,4 Ghz Athlon 1 GB Ram, 160 GB UDMA6 HDD

I use jack with realtime priority 60, 44,1khz and 256 frames (latency of 11,6ms says qjackctl, ardour says 5,8ms) with my M-Audio 2496 Audiophile (ice1712 chip).

When I use Ardour, I get after a while the message the Ardour was too slow keeping up with the data flow and looses the connection to Jack. In Jack I get 1-2 Xruns, no other message.
Currently I’m mixing a 10 track mix, which shouldn’t be too much for the system. I have to save and restart ardour to fix this, a simple reconnect doesn’t work.
At my current mixing state, I have a 44 % DSP load, with buffers at p: 50-99% c:99%

Any idea where this could come from?

The other problem is the freaking plugins… sometimes they go crazy and create feedback which did already hurt my ears and monitors heavily. This is very bad. The TAP Reverberator just freak out and put the channel on about +60db into the read, which my monitors answered with a damn loud unhealthy pop.
The sound was off afterwards, I had to completely restart the jack server. This also happened with GVerb.

Any known issues here? At the moment my sound system work worse than anything I’ve seen in Windows, because there at least you’re hardware doesn’t get screwed…
I’m a little desperate, so any advice is appreciated. I’m not too heavily in Linux, code, debugging, bug reporting and on. I’m willing to investigate and spent hours as I did before searching for the problem.
Maybe it’s a bit much and I should have split the problems, but just tell me.

Thanks a lot,

You should try the current stable release 0.99.3. If I remember correctly, there were some fixes which might fix these pops etc. Also, check that you have the most newest available versions of the plugins installed (alas, debian might not include the newest ones).

Also, you should check your hard drive parameters with hdparm and make sure DMA is enabled. Without DMA enabled, your disk performance will suck.

If you continue running into problems with plugins, you should try narrowing down which plugin is causing the problem.

It’s quite difficult to analyze all these issues at once, but start with this.


thanks for answering. I already tuned my hdd with hdparm. My hdd runs with dma enable, on udma5 mode (the hdd could do udma6, maybe I give that a try). The other options are also good, at least to my knowlegde and what I read about it.

Any other ideas about that?

It’s bad that debian unstable hasn’t Version 0.99.3 of ardour already - I thought Debian unstable is bleeding edge.
I tried to compile Ardour 2.0 already and ran in lots of problems and had no success compiling it. Ok, I’ll try that again with 0.99.3.
Of what I know, the plugins that came with debian are the newest ones - I’m shure with Steve Harris’ plugins and the TAP plugins, I’ll check the rest.