Ardour3 NSM support

I was glad to see that Ardour3.1 now has NSM support, but I find that it has broken my NSM setup with Ardour3. I am interested in using NSM to start Ardour3 with a specific session. This worked fine when Ardour3 did not have NSM support, because I started Ardour3 as an “NSM proxy” client and supplied the session pathname as an argument to the “ardour3” command. Now, with NSM will only start ardour3 as a normal client and command line arguments are not accepted for normal clients (as far as I can tell). Instead of opening the session I want, a new empty session is opened in the “NSM Sessions” directory which is not what I want. Well, maybe this is more of any NSM question than an ardour3 question, but can I get NSM to start ardour3 with the session I want rather than an empty session?

Ok, I started recreating - my session, and I see that NSM will restart the new session then way I configured it. So I guess I have to entirely recreate my Ardour3 session to use NSM. I tried my old method of starting Ardour as a proxy client but NSM was too smart for that, and just opened any empty session. Well, maybe the real problem is NSM which does not allow command line arguments for its clients. Its also annoying because I do not see how you can use a template if you want to use Ardour with NSM.

Ok, I see if you want to use a template you have to create it within NSM (i.e. create an Ardour session with the tracks and buses you want) and save that as an NSM session. To use that template, you copy the NSM template to a new NSM session. So the regular Ardour template support is bypassed. And to answer my previous post, I think NSM does not support loading Ardour3 sessions created outside of NSM.

Hmm don’t know enough about the NSM API to know whether it is possible or not, but would be worth filing this as a feature request in Mantis.


Another feature of NSM is that it puts session data in a session directory by default ~/NSM\ Sessions. This means your Ardour session directory gets put there. This feature makes me think it may not be possible to have NSM open a pre-existing Ardour session due to the organization of NSM. I think it more info is needed on NSM before I make an Ardour feature request. However, understanding how NSM works, I think I can work with it as is. Actually I do not want my Ardour sessions in my home directory, so I copied my NSM\ Sessions to my music partition and symlinked to it from $HOME which seems to work fine.

You better post your issues at the NON community:

I have the same problem and found this thread while looking for a solution. Did anyone get any further with this? In short: is it possible to start Ardour3 from NSM and load a preexistent Ardour session (made outside NSM)?

Adding to the previous question: does anyone have experience on using templates with Ardour through nsm? Are the Ardour templates created in one nsm session available in another?
Regarding nsm’s templating system the doc says :
" Templates are supported in by the Non Session Manager via duplication. Clicking on the Duplicate button with a session open will prompt the user for a new session name. The daemon will then perform a recursive file copy of the session and open the copy.
Obviously, this should be avoided for sessions containing audio data, as the copy would be very time consuming."

As I understand it, one should not rely on nsm templates to work with ardour sessions (it would copy the whole audio stuff). Hence my first question: has anyone got success in using Ardour’s own templating system with nsm?

I don’t have much to add about supporting Ardour templates on NSM as far as I can see it only works the way you describe as copying as existing NSW session. I’ve had other problems with NSM session and Ardour - frequently Ardour claims to have crashed when I start it via NSM. I’ve also got one NSM session in which the Ardour session crashes when started my NSM, but will start directly. However, all these problems are not quite reproducible so I have not filed bug reports.

You need to report a bug if you want to have your issue solved

Ok. Thanks for the informations! At least I know I haven’t missed an obivous feature…