Ardour3 midifile import problem

I use Ardour3.3 with KX Studio Ubuntu 12.04 64bit.

When I try to import midifiles ardour 3 crash completely.

I start ardour from terminal but there is no more information about the crash.

any ideas?


Does this happen with the version from this site? If it does I would say file a Mantis ticket, and if you can, attach a MIDI file to it that crashes it along with your information about how to reproduce it and a crash report.


It’s the last version from LP-PPA-kystudio-team/precise (Ubuntu). Version 3.3-1+fixed1~precise1.
I did some tests. In the moment the import of a midifile is mostly working. Some times it crash.

This is the terminal output:
0x7f089c0dac00 note 38/0 was already on, now at 2
0x7f089c0dac00 note 38/0 was already on, now at 2
ardour-3.3: …/libs/ardour/ virtual ARDOUR::framecnt_t ARDOUR::SMFSource::read_unlocked(Evoral::EventSink&, ARDOUR::framepos_t, ARDOUR::framepos_t, ARDOUR::framecnt_t, ARDOUR::MidiStateTracker*) const: Zusicherung »time >= start_ticks« nicht erfüllt.


Well the first step is going to be testing with the binary from this site as that is the only officially supported version and see if it causes an issue there. If it does then we need to look at the midi file itself.


Ok i just gave this a quick test and can confirm that importing a midi file causes an instant crash, ive not got time to submit a bug report just now (out fishing today) but ill try and get one submitted.

This was on a project that i had already setup with a couple of audio tracks and a bus with reverb but has yet to have any audio data recorded.

As soon as i double clicked the midi file, ardour was gone.

So it looks like this bug is present in the binaries from her aswell as what is built for kx studio.

If your wanting to do midi work id stick with 3.0 until the bugs are worked out.

veda_sticks: language matters. i can import various MIDI files here without crashes. if you have one (or more) MIDI files that caue a crash on import, then we need to look at those files to find out why they cause a problem when others do not. Please file a bug report and attach the file(s).

No problem, ill submit a bug report with crash data and include the midi file, it was a midi file from Final Fantasy 7 game which consists of multiple midi tracks and it has gm midi data at the beginning of each track to set instruments for general midi.

I’ll give this a test in ardour 3.4 aswell once i get it downloaded and installed.

Ardour 6.9.0~ds0
“After Bach”
(rev 6.9.0~ds0-1)
Intel 64-bit
Ubuntu studio 20.1 64bit.
I’m glad I’ve found this thread. For once, I’m relieved it’s not just me. It’s not a major problem, I’ll wait and see if anything happens,
EDIT. I’ve been thinking…darken the room, black laced coffee…As a gigging entertainer I needed my midifiles mobile. I’m now studio bound, so, ardour does everything admirably with audio and the “export to audio” function is the slickest known to man. So, without the need to hawk my midi creations around ardour does everything in the box.I feel my posting finger coming to rest. Thanks again all. P.
EDIT 2. I’m off to make my masterpieces from ardour take on a meaning in “blender”.
I may be a while!

Well, we’ve come a long way since Ardour 3 and a lot of issue with importing MIDI have meanwhile been addressed. It has been a while since we came across a file that didn’t import properly, but yes, you are not alone.

Could you share the .mid file that causes the crash? Ideally attach it to a bug report at – If you cannot share it publicly we can probably arrange something to get the issue addressed as well.

As I haven’t learned how to export to .midi from ardour I can’t furnish a file built on multi tracks. Thus far I’ve only tried to import anyoldfile.mid. I’ve yet to try importing the three example files on this forum. I’m running the version of ardour that arrived withy ubuntustudio 20.1. should I ditch it in favour of a download from ,(Installing software in Linux is something else…
…) Regards. P.

Installing Ardour is a no-brainer. Can even keep as many versions in parallel as you have disk space.

was this step that produced the crash?

A MIDI file exported by Ardour also imports correctly. I expect that it is some old file that cause the issue. We’ve seen that in the past.

Very helpful. I remarked because I find it difficult. No brainer for you. It seems gnome installer doesn’t come down with Ubuntu studio. Advice from Foss.

No worries.

When you download Ardour from install instructions are provided (and also sent to you by email is you are logged in while downloading/purchasing).

There is a page to explain this and users on the forum also help out if neither is sufficient, or you run into problems.